2

I have Macbook Pro 13" 2014. Everything was working fine. But suddenly it stopped recognizing some gestures. I was always using built-in trackpad. But now my computer doesn't respond to tap or physical click. 3-finger gestures are not recognized as well.

A few hours before this, the computer was working fine. Then I left my laptop open for about 40 min. When I returned, it looked like the mouse button was clicked and stuck in the clicked state (I don't have a mouse, it is just how it looked like). Of course, I tried to stop it, but nothing helped... The laptop was unusable at all, so I just restarted it by holding power button.

When I connect a standard PC mouse, I get the same outcome - 2-finger tap, zooming, swiping work. But not clicking.

If I go to settings and set the secondary click to be the click in the right bottom corner of trackpad - this click is recognized.

Clicks are also recognized in login screen, but not recognized in recovery mode.

When I log in - clicks are detected, so I am able to log in. But it stops responding to clicks after that. Even when I log out, the clicks doesn't have any effect. I cannot login back!

I believe this is not a hardware problem and I can fix it as soon as possible. But how? I cleaned it, performed reboots, cannot reinstall OS though - simply cannot click "next"!

On the forums say that it might be a battery problem, but from the outside I don't see anything abnormal. And I cannot open the laptop and look at the battery.

How to make my laptop recognize clicks? Please, help me!

UPD: I added a few details.

  • Might as well be a hardware issue (things don't always go with your hope). My advice is to make a Genius Bar appointment. You are clearly under warranty (unless you tinkered with something). Unless you are confident enough, I would advise against opening a unibody MBP yourself. All the guides I've seen on iFixit are pretty complicated. – 4ae1e1 Dec 24 '14 at 2:08
  • @ksh But how come system can detect clicks when i am on the login screen? I believe there is something in software that doesn't recognize the gestures... Also, I want to mention one important detail... I will update my question. – ntoskrnl Dec 24 '14 at 4:46
  • I said "might", in a comment. I was just making a generic suggestion. Troubleshooting remotely on a Q&A site usually isn't effective. – 4ae1e1 Dec 24 '14 at 4:48
  • Are any bluetooth devices connecting by chance? Like a mouse in your laptop bag or a trackpad somewhere? – InChargeOfIT Dec 24 '14 at 5:50
  • @InChargeOfIT nope... And i tried to turn off wifi and bluetooth... It all happened out of nowhere.... – ntoskrnl Dec 24 '14 at 5:52
1

One Queston, then my suggestion.

When I connect a standard PC mouse, I get the same outcome - 2-finger tap, zooming, swiping work. But not clicking.

Did the machine respond normally to the mouse click?


Given your description of the issue, here’s how I would proceed:

  • Make sure your software and firmware is up date. Apple Logo > About This Mac.. > Software Update
  • Disconnect all peripheral devices. Hold down Shift at the boot chime to enter Safe Mode. If you can’t recreate the problem, it’s software related. The most likely culprit would be a third party driver that's interfering with your trackpad functionality.

  • Run Apple Diagnostics on the machine. Do so two times, back to back, regardless of the result. The machine must be plugged into your MagSafe. If the machine is not plugged in, you may receive a false positive that there is an issue with your battery. If you do receive an error code, follow the on screen instructions. Make an appointment to bring your machine in for a definitive diagnosis and servicing.

  • Follow these instructions to reset the SMC. Components such as the keyboard lights, fans, battery, power supply, and trackpad all rely on this controller. If one is behaving abnormally, a reset may do the trick. See if the issue persists. If it still does, then proceed to reset the PRAM.

  • Make an appointment with Apple to bring the machine in for a free and definitive diagnosis. Remember, your machine is covered under warranty. The last thing you want to do is void that warranty. Especially when you can’t even pinpoint the problem. Simply unscrewing the bottom enclosure will void it if detected. So, do not try a DIY fix. Bring it in. If it’s a hardware problem, they’ll fix it free of charge. If it’s a software issue, they’ll proceed accordingly (see below) until the problem’s solved. No matter what the issue is, as long as it’s under warranty, they assume responsibility for fixing it until it’s fixed. I don’t mean to come off as preachy, but I can't stress this point enough.

  • I see no purpose in reinstalling OS X before diagnosing the issue. It’s the first step Apple will suggest to take after the hardware checks out. Not before. However, if you do so, I’d recommend a clean install (wipe the machine completely, then selectively restore your data).

Best of luck.

  • In safe mode the problem still persists. The diagnostics doesnt report any issues. Resetting SMC and PRAM didn't change the situation.... Going to apple. – ntoskrnl Dec 24 '14 at 8:21
  • An interesting thing: when I connect a standard PC wired mouse in the login screen it works. Then it still works in the system (i have set the option to ignore trackpad). Then when i disconnect the mouse, and try to tap with trackpad, it detects my click and then holds it. Then it stops responding to clicks. Plugging the mouse back doesn't help. The mouse left-click doesn't work anymore... – ntoskrnl Dec 24 '14 at 8:26
  • So for now I am using mouse. Unless I disconnect it - it works. I think in the service center they will tell me what is wrong and fix it. Thank you anyway :) – ntoskrnl Dec 24 '14 at 8:29
  • @ntoskrnl You’re welcome. It’s an odd problem, really. Outside of the diagnostic test, all the evidence points to a faulty trackpad in my estimation. The symptoms you describe are very similar to those of the defective trackpads of the “swollen battery” age of MacBooks. Exactly on point in regards to servicing - you’ll get a definitive answer there. Feel free to report back with the results. I’m certainly curious. Best of luck, again. – njboot Dec 24 '14 at 10:12
  • 1
    they tested it and it turned out to be a hardware issue. I thought apple devices are perfect... :) – ntoskrnl Dec 25 '14 at 11:40
-1

I had the exact same problem, turned out to be a Bluetooth mouse connected, lying in a drawer with the mouse button pressed :)

  • Hi Eric, thanks for your answer, but the OP already discarded that as an option (look at the comments). – Jaime Santa Cruz Jun 30 '15 at 15:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .