1

I tried to install Windows 8 using the bootcamp assistant, but when I got to this screen,

enter image description here

The BOOTCAMP partition created by bootcamp wouldn't accept the windows install. Meaning, I reformatted it, and normally the little sun button "New" would then allow me to proceed with the Windows install.

I thought it was very weird so I instead deleted the partition, which turned into a 47.3Gb of Unallocated Space.

I tried formatting said unallocated space which created a bunch more partitions, but ultimately the same problem persisted: Can't install Windows.

In OSX, the Disk Utility wouldn't let me actually delete or remove the partitions so I went back to the Windows install menu and turned all the undesirables into unallocated space.


Here's what my Disk Utility looks like now:

enter image description here

As you can see there's some purple stuff at the top and some dark-grey stuff at the bottom, which I imagine represents free space?

Finally, here's a diskutil list readout:

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage                         121.0 GB   disk0s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:          Apple_CoreStorage                         948.5 GB   disk1s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           *1.1 TB     disk2
                                 Logical Volume on disk0s2, disk1s2
                                 A952E93D-0902-4BEC-B4D2-93A8BB1CDDD0
                                 Unencrypted Fusion Drive
/dev/disk3
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *16.0 GB    disk3
   1:                 DOS_FAT_32 WININSTALL              16.0 GB    disk3s1

Questions:

  • WTF happened?

  • How can I reset everything to the way it was so I can try bootcamp again?

  • More specifically, how do I add unallocated space to my primary OSX partition?

  • List item

Please help!

Thanks in advance.

0

I don't know what exactly happened, usually it works.

To get back to your original disk layout, just format the unallocated space with the Window installer (FAT32 or NTFS), boot to OS X and open Bootcamp Assistant. Skip building an installation medium or downloading any drivers, just remove the Windows Partition.

If that doesn't work give me a comment. There are several solutions to restore the original disk layout.

Item List:

Actually you have a Fusion Drive.

To build a Fusion Drive several physical disks are combined to a CoreStorage Logical Volume Group.

  • Disk0 is your physical SSD

  • Disk1 is your physical HDD

  • Disk2 is your logical Macintosh HD volume (CoreStorage Logical Volume) which resides in a Logical Volume Group spanning over disk0s2 and disk1s2. Disk2 is no real physical disk like disk0 and disk1 but in the Disk Utiliy context an own "logical" one.

  • Disk3 is your thumb drive containing the Windows 8 installation environment.

0

klanomath is essentially correct.

It's been a while but when you run Bootcamp it creates a bootable thumb drive with the Windows installer, Apple drivers and files necessary to boot your Mac. When that part is done it prompts you to reboot and after a while gives you a simple graphical view of your disk space that you can drag left to make the Windows Partition bigger and the Mac's smaller.

Pardon the statement of the obvious but that is what should have happened, is that the way it went?

Once the partitioning is done you boot into the Windows installer and get the partition chooser you showed at the top of your post. At that point you should do nothing but verify that you have the correct partition selected and click on NEXT, ignoring all of the other buttons.

That is how it should go. It is easy enough to be confused by the options or even just click the wrong thing. Hell, I've done it myself and wiped my Mac's drive, thank god for backups!

If something did not go that way run Bootcamp from the start and recreate your install media and try again. Note down every mouse click and thing you typed, so if it fails again we can figure out where...

0

What worked for me: Don't format or create new partition, just select "Unallocated Space" during the Windows install and click "Next"

Anything else will result in a failure.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .