0

Whenever I disconnect a mouse (a generic cheapo Lenovo branded one) and reconnect it, I lose the ability to right click using the mouse. I have to resort to using CTRL+Left click. I have tried it with a different mouse (non Apple) and experienced the same problem. I also tried switching the secondary button to Left just to make sure it wasn't something specific with the L/R button. When I do that, the secondary click doesn't work even if it is the left button.

The only way I have solved this is to do a full restart. I suspect logging out and back in may fix this.

I think this is a driver issue somewhere. Any Ideas?

I am running Yosemite with all the latest patches. I've had this problem since Mavericks (my first OSX).

0

It seams like you have some kind of incapability between your mouse and computer.

Try with enabling right clicking on both your trackpad (if you have one built in) and your mouse from Mac OS Settings. Also, if you have the possibility try with an another mouse and see if it work.

Try googling your mouse model and Mac OS problems or something like that.

0

I eventually found the problem. It seems that my USB hub had some sort incompatibility with OSX. I tried a different USB hub (not a super cheap import this time) and everything appears to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .