8

I have 2 monitors for mac, one extended the other.

How do i switch virtual desktops on one monitor only?

For example, When I do 4 fingers swipe left/right on screen1, I expect the switching happens on screen1 only.

BUT both monitors will switch virtual desktops at the same time, how do i avoid that?

  • What OS X version do You have? If Mavericks or newer go to Preferences -> Mission Control -> Displays have separagte Spaces. – Mateusz Szlosek Dec 22 '14 at 15:28
  • Although this answer was placed here after I put it as an answer it would be helpful for you to accept it so it is listed as solved. – markhunte Dec 23 '14 at 16:26
10

I am not on a My Mac at the moment, but in the Mission Control Preferences there is a setting to have the spaces work independently. Go to Preferences -> Mission Control -> Displays have separate Spaces.

enter image description here

2

To add to @markhunte, the switching of desktops seems to depend on where the focus or mouse, is. I have 2 external monitors and 3 spaces on my primary display. When I add a space to an external monitor, the key-combo of Control + <- or -> will move the space where the active app or my mouse is located.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .