2

I keep all of my music in a folder on my back up drive. I use Media player to edit and genre categorize the music. Then copy / transfer the folder to Itunes which converts the music to ACC format.

My problem is when I add a new song or album(s) to my master folder, Itunes wants to copy the whole folder again causing massive duplications and it wants to change my genre categorization on some songs.

It also sometimes takes songs in an album and separates them listing each separately. So instead of on e album listing 15 songs. I get 15 listings of the album with one song listed.

3

Open iTunes preferences and click advanced.

Uncheck the Copy line item...

enter image description here

You still have to clean up the old dupes, but any new imports will be left on the filesystem where you stored them and not copied or moved to where iTunes would like them to be stored.

1

To avoid the multi-listing of the album containing one song each, marking the whole album as a compilation (even if it's no real compilation) often helped me.

Example (real compilation this time):

  1. Select all tracks belonging to an album

    enter image description here

  2. Get info -> Details -> enable "Album is a compilation..."

    enter image description here

  3. Result: only one album

    enter image description here

-1

You can try this article to prevent iTunes from copying files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .