3

I have a Mac mini running 10.6.7. I have set the screen saver to be automatically activated after 15 minutes, and the session to be locked a while after that.

But sometimes, the screen saver stops working. The screen remains on and unlocked indefinitely.

I sometimes suspend the machine manually (for example by pressing --). This will suspend it properly, but when I come back to it sometime later I will often see that it is on again and no screen saver.

This problem appears after I have been using the computer for a while, and then doesn't go away until I turn it off (or perhaps just log out). It could perhaps mean that some screensaver process has died and not restarted automatically.

Can anyone help me figure out what is going wrong, and what I can to to fix it?

Update: In the end, I found the application causing it to not suspend. It was SqueezePlayer. I didn't any really good suggestions how to find the culprit, though.

  • What are the keys for "suspend" ? Does it work on macbookpro sierra? – Pacerier Dec 10 '17 at 14:36
10

I cannot tell about screensaver for sure, but you can use pmset -g to show which process is disturbing sleep (think this first appeared in 10.6.7)

# pmset -g
[cut]
sleep       0 (imposed by 1517)
[cut]

this means that pid 1517 is preventing the system from sleeping.

# ps ax |grep 1517
1517   ??  Rs     1:59.76 /System/Library/CoreServices/backupd 

This shows that this is the backup daemon running.

  • My problem is fixed, but I still see "sleep 0" imposed by Chrome, but perhaps this is still useful if you have the problem. – dkagedal Jul 14 '11 at 11:35
  • did pmset -g in terminal and found Firefox preventing screensaver from working! – user151341 Oct 8 '15 at 20:11
1

I have seen this caused by some poorly behaved programs, notably Dungeon Crawl Stone Soup prevents the screen saver from working at all while it is running, whether full screen or windowed. You might record ps -ef from when it works and when it doesn't and look for any additional programs running that might be blocking the screen saver.

I've also seen some cheap mice develop "jitter" which makes the computer think it's being moved; this can also result in the machine waking up from suspend.

  • I have an Apple wireless trackpad. – dkagedal Jun 21 '11 at 23:16
  • is the trackpad surface clean, and there is nothing metallic/conductive that could be brushing it's surface? – Fake Name Jun 22 '11 at 0:23
1

MacKeeper actually has a user setting that was turned on by default to prevent sleep. Click on the MacKeeper helmet in the title bar and look for the option.

1

I also had this issue after upgrading to Sierra. I got the screensaver up when it was less than 5 minutes but not 10 minutes or more. I went into Apple/System Preferences/Energy Saver and changed Computer and Display Sleep to more than 10 minutes: this way, the screensaver kicks in before the sleep does. Problem solved. Hope this helps.

0

Open up Activity Monitor and when you see the list of processes running, right click one of the column headings (e.x. "Process Name") and check "Preventing Sleep". This will add another column with "Yes" or "No" values per process. If you see one with "yes" in that column, it means that this process is what is keeping your mac from sleeping.

  • Does the same flag also prevent the screen lock? – dkagedal Jan 10 '16 at 22:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .