0

Synopsis

Since upgrading to Yosemite, when my MacBook automatically turns it's screen off to conserve energy it also logs out which bugs me because all of my processes are killed off; this never occurred on Mavericks.

Also, since upgrading to Yosemite why is there now two log-in screens?

  • When the machine is booted there is one login screen;
  • When the machine is powered on from sleep mode you instantly need to login, then once the mac has booted and all devices are loaded (after ages) you need to login a second time;
  • do you use FileVault? or, is your keychain login different to your user login? – Tetsujin Dec 22 '14 at 11:16
  • My keychain user is the same as my system user and I don't think I use FileVault. – ash Dec 22 '14 at 13:01
  • Looks like 2 issues here; 1)The option to auto-logout users (as mentioned in the existing answer) set to the same value as the sleep setting would produce the effect you mention above... this and/or in combination with the "lock screen after..." setting in Security & Privacy does this. 2) You have the firmware password set from Recovery Mode, as well as the standard, user password. If these sound like a possibility we can write it up as a proper answer. – forgotstackxpassword Apr 28 '16 at 21:17
2

Isn't it the advanced log out feature found under Advanced in Security & Privacy?

I've disabled "Log out after # minutes of activity" on El Capitan (see screenshot) to keep my desktop session open regardless of time.

I did check the "Require an administrator password" to prevent normal users to change a locked system.

Advanced - Security & Privacy

You might also want to check your Energy Saver settings; particularly under the Schedule... button that could cause your system going to sleep.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .