3

I'm using OS X Yosemite and in Pages table jumps to the next page (and leaving text on the first page) when it gets too big, how can I stop it?

2

A table in Pages inherits its page break settings from the line on which it is located. (You can imagine the table is a huge character on a line).

To change the behavior of that line place the cursor at the end of the line above the table and press arrow right, moving the cursor to the table row. (Sometimes you'll see a blinking cursor along the left side of the table).

Now, choose Text formatting and click "More" and set up your paginations and breaks to your liking.

This way you can change the behavior of each table to break across lines or not as you see fit, and you don't have to change the behavior of all other text to do it...

| improve this answer | |
1

Try to set right height of your rows and measure them not to jump into next page. Second variant - add more length to your columns in table to stretched content.

| improve this answer | |
1

Select the whole document and in the Format panel on the right select the "More" tab and uncheck the "Prevent widow & orphan lines" option. The table will then be arranged sensibly. For some reason Apple thought it better to make the incoherent behaviour the default.

enter image description here

| improve this answer | |
0

There seems to be no solution that I can find. (Apart from making the text or margins unreadably small.)

It looks like you need to make an Enhancement Request.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .