6

Rented a movie from iTunes. Tried to play it. Got error: "This movie requires QuickTime, which is not supported by this version of iTunes."

Movie is 720p HD mp4.

Have tried to open the movie in QuickTime but won't open. I suspect that's a DRM issue but QuickTime isn't saying.

I'm not sure if it's related or not but once the download completed I got an iTunes error (We could not complete your iTunes Store request. An unknown error occurred (3001)).

Has anyone else seen this lately? Anyone have any ideas?

James

1

Found the answer here: http://support.apple.com/en-us/TS3771 Basically, you need to get iTunes to startup in 32-bit mode.

  • 1
    I wish it were so. Unfortunately tried that before posting. That solution appears to have worked in previous iTunes version (going back to 10.4, I guess) but now iTunes says it requires 64-bit mode. – James Roscoe Dec 22 '14 at 14:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .