20

The location in the weather widget of the notification center is permanently wrong since September 2014. I was in Ampus for vacation. But today I'm at home and the location is not changing!

Weather widget with wrong location

If I click on the i in the upper right corner, I can't change it manually.

enter image description here

Does somebody know a solution?

  • For me it looked like a bug related to the widget trying to hide the duplicate weather info for the current location if you've also added that location manually. – Andreas Jul 29 '15 at 15:13

11 Answers 11

11

Press the i icon in the top right of the screenshot you provided. There you can change the location for weather. Edit

Did a quick search and it seems to be a bug in yosemite. Found a french website with a solution, link . it seems that the location for you weather is stored in ~/Library/Containers/com.apple.ncplugin.weather. I don't know if this is a temporary fix

  • 1
    Thanks for your answer, but I can't remove the location. The little arrow indicates that the current location should be used! But it will not actualized automatically. I changed the question. – Tim Dec 21 '14 at 21:07
  • Check if your region is correct in your system preferences under language & region. When it is correct, change it to a random location, reboot the mac and then change the region back to normal – Jules Dec 21 '14 at 21:10
  • Tried it and it is not working! – Tim Dec 21 '14 at 21:15
  • Did a quick search and it seems to be a bug in yosemite. Found a french websie with a solution, forums.macg.co/mac-os-x/… . it seems that the location for you westher is stored in ~/Library/Containers/com.apple.ncplugin.weather. I don't know if this is a temporary fix – Jules Dec 21 '14 at 21:19
  • 1
    That works. I deleted that folder. After that everything is fine. When you change your answer, I can accept it as correct! – Tim Dec 21 '14 at 21:31
21

Go System Preferences > Security & Privacy > Privacy [tab]
Uncheck and recheck 'Weather' and it's back to normal

See below img

enter image description here

  • 5
    This should be the accepted answer. – Adam Johns Mar 5 '15 at 4:37
  • Doesn't fix it for me – shim Mar 18 '15 at 19:50
  • I think this would the better solution. But I can't reproduce the problem. Everybody for whom this solution works should upvote this answer. – Tim Mar 19 '15 at 8:19
  • @shim I tried this trick with no results until I deleted and re-added the weather widget in notification center while location permission was denied. – Andreas Jul 29 '15 at 15:07
4

Open up System Preference, go into the "Security" pane, and then, within "Location services" check whether the weather widget is allowed to get your current location.

If it is currently checked, and your location is still not correct, uncheck and re-check it again. Note that you might need to unlock the preference pane by clicking on the lock icon in the lower left corner first.

  • THIS, my friends, should be the accepted answer. It is very funny to see the other options rose to the top when they are sort of inaccurate versions of this one, which is closest to perfect. – estephan500 Mar 16 '18 at 13:23
2

I found what may actually cause this problem. The weather widget uses location services to determine your home location. It caches the last location it found. I use my computer over wired LAN at home and location services does not work without WiFi on. So when at home it could never resolve my location and defaulted to the last location which was incorrect.

Turn on your wifi, and remove the wrong location from your weather widget. It worked for me.

0

Go System Preferences > Security & Privacy > Privacy [tab] Click the lock on the bottom left of the window and enter your password. Uncheck 'Enabled Location Services' and press the lock in the bottom left again. Once more, press the lock to unlock, Enable Location Services again and lock again.

This solved the problem for me.

0

I did what Lucas said, and at first it didn't work. I tried again an this time after I had unchecked the Weather in the Location Services I: locked the preference pane, went to the notification center clicked the i in the upper right hand side, then removed the incorrect location, finally I unlocked the preferences pane and checked Weather in Location Services.

0

System Preferences>Security & Privacy Click Privacy tab Select "Location Services" Uncheck "Weather"

The incorrect weather location should disappear. Rechecking "Weather" should automatically bring up the correct weather location.

0

I had this problem too. I clicked the "i" icon on the bottom right of the widget and once it flipped I typed in my zip code (Australian) and it recognised it as a Sydney zip code and allowed me to select the Sydney time zone. This worked a treat! Nothing else seemed to work.

0

If you hover over the Weather widget there is a little 'i'. Click it then re-enter your location.

0

remove from Notification center then add back..

  • 3
    We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed. – Tetsujin Jan 7 '17 at 7:16
-1

Press the "i" icon to the right of "Weather", then drag the vacation spot down, so it is no longer at the top of the list. Then delete it.

If you don't drag it down from the top of the list, it reappears in about ten or fifteen seconds.

You must log in to answer this question.

protected by Tetsujin Jan 7 '17 at 7:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .