1

My iMessage is not working after I have changed my MAC address. I have restored my original MAC address, but it is still not working. My phone is an iPhone 4s, 6.1.3 jailbroken.

I changed my DNS, restored with iLex RAT (because I don't want to upgrade to iOS 8), then reset network settings, but it is still not working. How can I resolve this?

  • Interesting, so how did you change the MAC ? – Ruskes Dec 21 '14 at 18:07
  • Needless to say you have broken the authentication protocol with iMessage. It is not clear how you "restored" the MAC and if it was done correctly and I do not know if the iLex RAT will do that. – Ruskes Dec 21 '14 at 18:24
  • Why all the up votes? "I pushed some random buttons. I broke stuff. Haalp!!" -1 from me. You'll probably need to get your provider to restore the association, or Apple. – Tetsujin Dec 21 '14 at 18:32
  • guys, there is no solution ? – Engin Dec 21 '14 at 18:56
  • 1
    Try restoring your phone to factory defaults. – ecnepsnai Dec 21 '14 at 19:12
1

I simply signed out of my apple id, signed into a different one, then signed back into my initial one and it worked. Hope it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .