I shared a web page via Safari (8 on Yosemite) once. Now the last recipient shows up in the menu. How can I delete it from there? See picture for how it looks.

Share menu on Safari including the last recipient

  • Try to clear the history of your browser. – k1r8r0wn Dec 21 '14 at 15:48
  • I would like to keep my history. Is there a way to re-import it after clearing? – dlrlc Dec 21 '14 at 16:33
  • 1. Select "Macintosh HD", click "Users". 2. Double-click your user name. 3. Double-click "Library". 4. Click the "Safari" folder. 5. The "History.plist" is the Safari history of documents, back up it. 6. Then after cleaning, move this file into this folder back. – k1r8r0wn Dec 22 '14 at 3:20
  • Safari history is no longer kept in ~/Library/Safari/History.plist. Also, support.apple.com/kb/PH19215?viewlocale=en_US&locale=en_US does not list Sharing recipients as items cleared when you "Clear History and Website Data..." – pseudon Dec 22 '14 at 4:46
  • Re-importing my history worked! But the last recipient was not deleted in the cleaning process as pseudon said. – dlrlc Dec 22 '14 at 14:27

This was a long time ago, but I found out how to delete the recently shared items and haven't answered yet. So here is how it goes:

Delete the plist file:

Old: ~/Library/Preferences/com.apple.sharekit.recents.plist

New: ~/Library/Preferences/com.apple.preferences.extensions.ShareMenu.plist

I forgot when exactly macOS changed the file location, and maybe both file are present after an upgrade.

You can use plutil -convert xml1 <filename> to convert the plist into a human-readable XML format if you want to inspect it.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .