1

I'm having a problem with my Retina iMac regularly generating a "A graphics problem has been detected" error. The iMac has the AMD Radeon R9 M295X option.

At the end of the day I walk away from it and leave it to its own devices. I don't power it down or explicitly put it to sleep. In the morning I expect to wake it up and carry on, but it often needs to be powered on and boot up.

When it reboots I see a dialog with the "A graphics problem has been detected" error message.

In the console log I see a series of "Trying restart GPU" messages". Below is the last of these messages and all the log entries before.

Anyone know how to fix this?

21/12/14 3:52:44.000 am kernel[0]: Trying restart GPU ...
21/12/14 3:52:44.905 am com.apple.xpc.launchd[1]: (com.apple.DumpGPURestart) Service only ran for 8 seconds. Pushing respawn out by 2 seconds.
21/12/14 3:52:46.919 am DumpGPURestart[1410]: Saved gpuRestart report for kernel to /Library/Logs/DiagnosticReports/Kernel_2014-12-21-035246_newton.gpuRestart
21/12/14 3:52:53.000 am kernel[0]: [1:0:0] GPU HangState 0x000000c0, HangFlags 0x00000007: IndividualEngineHang 1, NonEngineBlockHang 1, FenceNotRetired 1, PerEngineReset 0, FullAsicReset 1
21/12/14 3:52:54.000 am kernel[0]: 0000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : 0x00000000 : 0x00000000 
21/12/14 3:52:54.000 am kernel[0]: : ** GPU Debug Info End **
21/12/14 3:52:54.000 am kernel[0]: ------------------------
21/12/14 3:52:54.000 am kernel[0]: GPURestartReportEnd
21/12/14 3:52:54.000 am kernel[0]: Trying restart GPU ...
21/12/14 3:52:54.875 am com.apple.xpc.launchd[1]: (com.apple.DumpGPURestart) Service only ran for 7 seconds. Pushing respawn out by 3 seconds.
21/12/14 3:52:57.890 am DumpGPURestart[1411]: Saved gpuRestart report for kernel to /Library/Logs/DiagnosticReports/Kernel_2014-12-21-035257_newton.gpuRestart
21/12/14 3:53:27.298 am apsd[52]: Failed entitlement check 'com.apple.private.aps-connection-initiate' for ManagedClientAgent[1412]
21/12/14 3:53:27.298 am apsd[52]: Peer connection [pid=1412] lacks APSConnectionInitiateEntitlement
21/12/14 3:53:32.299 am ManagedClientAgent[1412]: No Device Enrollment record info was found
21/12/14 3:56:05.000 am kernel[0]: PM priority notification timeout
21/12/14 3:56:06.000 am kernel[0]: hibernate image path: /var/vm/sleepimage
21/12/14 3:56:06.000 am kernel[0]: efi pagecount 67
21/12/14 3:56:06.000 am kernel[0]: hibernate_page_list_setall(preflight 1) start 0xffffff82114d5000, 0xffffff8211555000
21/12/14 3:56:06.000 am kernel[0]: hibernate_page_list_setall time: 569 ms
21/12/14 3:56:06.000 am kernel[0]: pages 3753650, wire 316199, act 1921147, inact 20159, cleaned 0 spec 13, zf 55501, throt 0, compr 0, xpmapped 0
21/12/14 3:56:06.000 am kernel[0]: could discard act 560471 inact 405794 purgeable 211784 spec 262582 cleaned 0
21/12/14 3:56:06.000 am kernel[0]: hibernate_page_list_setall preflight pageCount 316199 est comp 50 setfile 836763648 min 2147483648
21/12/14 3:56:06.000 am kernel[0]: AppleThunderboltNHIType2::prePCIWake - power up complete - took 2 us
21/12/14 3:56:06.000 am kernel[0]: AppleThunderboltGenericHAL::earlyWake - complete - took 0 milliseconds
21/12/14 3:56:06.000 am kernel[0]: [0x59c815000, 0x40000000]
21/12/14 3:56:06.000 am kernel[0]: [0x5dc815000, 0x40000000]
21/12/14 3:56:06.000 am kernel[0]: [0x0, 0x0]
21/12/14 3:56:06.000 am kernel[0]: kern_open_file_for_direct_io(0) took 4 ms
21/12/14 3:56:06.000 am kernel[0]: Opened file /var/vm/sleepimage, size 2147483648, partition base 0x0, maxio 2000000 ssd 1
21/12/14 3:56:06.000 am kernel[0]: hibernate image major 1, minor 0, blocksize 4096, pollers 5

Here's an abbreviated copy of the diagnostic report, referred to above

Event:               GPU Reset
Data/Time:           Sun Dec 21 03:52:46 2014
Application:         
Path:                
OS Version:          Mac OS X Version 10.10.1 (Build 14B25)
Graphics Hardware:   AMD Radeon R9 M295X
Signature:           c0

Report Data:

GPURestartReportStart
------------------------
[08] AccelChannel: sDMA1
Currently pending command from UnknownCtx
PendingCommandTimestamp: 0x000b2f57, TotalDWords: 0x00000000, GART Offset=0x00000001001d4700, stamp_idx=8, estamp=0x000b2f57
PendingCommandStart:
PendingCommandEnd
------------------------
[08] sDMA1HWChannel: Enabled: Not Idle
IndirectCommandSize: 0x00000040, LastReadTimestamp: 0x000b2f56, NextSubmitTimestamp: 0x000b2f65
------------------------
[00] HWRing: Enabled
RingSizeInDwords: 0x0800,  FreeSpace: 0x07ff, Head: 0x00000000, LastSubmitPosition: 0x00000000, Tail: 0x00000000
RB[0]_RPTR: 0x00000000, RB[0]_WPTR: 0x00000000
HWRingDumpStart:
0x00000000 <= ReadPtr <= Tail <= LastSubmit 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 
0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 .
.
.
.
.
0x00000000 0x00000000 0x00000006 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 
HWRingDumpEnd
------------------------
SRBM_CNTL  : 0x00000000 | CP_ME_CNTL  : 0x00000000
SRBM_STATUS: 0x20000a40 | SRBM_STATUS2: 0x00000040
GRBM_STATUS: 0x00003028 | GRBM_STATUS2: 0x00000008
------------------------
GPU HangFlags 0x00000007: AsicHangState 0x00000007, AsicResetRequirement 0x00000002
IndividualEngineHang: 1
NonEngineBlockHang  : 1
FenceNotRetired     : 1
PerEngineReset      : 0
FullAsicReset       : 1
GPU HangState 0x000000c0: Hung Engines: 
DRMDMA1/SDMA SPU 
------------------------
AMDTongaGraphicsAccelerator PCIe Device: [1:0:0] State: DISABLED, channelResetMask 0x00000100
Configuration: deviceBits: 0x41016938, capabilityBits: 0x30840300
TotalVideoRAMBytes: 0x0000000100000000 (4294967296)
------------------------
[00] PM4 Engine: Enabled: Idle
[00] GFX Channel: Enabled: Idle
[01] C0 Channel: Enabled: Idle
[02] C1 Channel: Enabled: Idle
[03] KIQ Channel: Enabled: Idle
------------------------
[01] DMA Engine: Enabled: Idle
[04] sDMA0 Channel: Enabled: Idle
------------------------
[02] UVD Engine: Disabled: Idle
[05] UVD Channel: Disabled: Idle
------------------------
[03] SPU Engine: Disabled: Idle
[06] SAMU RBI Channel: Disabled: Idle
[07] SAMU GPCOM Channel: Disabled: Idle
------------------------
[04] DMA1 Engine: Enabled: Not Idle
[08] sDMA1 Channel: Enabled: Not Idle
------------------------
[05] VCE Engine: Disabled: Idle
[09] VCE Channel: Disabled: Idle
[10] VCELLQ Channel: Disabled: Idle
------------------------
: ** GPU Debug Info Start **
: 0x00006938 : 0x000000e5 : 0x00000001 : 0x00000018 : 0x00009000 : 0x00000001 : 0x00000001 : 0x00006938 
.
.
.
: 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 : 0x00000000 
: 0x00000000 : 0x00000000 
: ** GPU Debug Info End **
------------------------
GPURestartReportEnd
6
  • it is telling you that there is report here: /Library/Logs/DiagnosticReports/Kernel_2014-12-21-035246_newton.gpuRestart look it up for clues.
    – Ruskes
    Dec 20, 2014 at 23:36
  • Also run Apple Hardware Test to check for problems.
    – Ruskes
    Dec 20, 2014 at 23:37
  • I'd just take it back to the store you bought it from as it is still under warranty.
    – amergin
    Dec 20, 2014 at 23:38
  • well that's another way to fix it :)
    – Ruskes
    Dec 20, 2014 at 23:39
  • I had looked that report, but nothing that made sense to me in it. I've added a trimmed version to the question. Make any sense to you? I'd like to be sure it's not a yosemite or generic hardware issue before sending it back.
    – John McC
    Dec 20, 2014 at 23:46

1 Answer 1

2

Turns out it's somehow related to the UPS the machine was plugged in to. Plugged into the UPS, gets a restart most mornings. Plugged straight into the wall, hasn't happened in 4 weeks. Tested both configurations several times and it's quite reproducible.

1
  • Bad power, of all things! That will cause all manner of hard-to-diagnose issues. I'd get that unit replaced before some other unlucky individual plugs something into it and gets their gear fried..
    – Mikey T.K.
    Aug 15, 2015 at 11:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .