1

I know you've been dealing with this for two years. However, none of the recommended solutions works for me. iTunes will play one song, and stop. Or, it will play one song - over and over and over. I am using iTunes vsn. 12.0.1, updated on 10/21/14, on a Mac running OS 10.7.5.

1

This is often caused by iTunes' insistence on only playing songs that are 'checked', even though you can't tell whether they're checked or not except in Songs view.

If you don't need the functionality that checking songs is used for (syncing with other devices, or limiting what appears in smart playlists), you can turn it off by unchecking Preferences > General > Show List Checkboxes. Then iTunes will play any selection you like without stopping.

If you don't want to disable checkboxes, as @Buscar웃 says, the Up Next list is your (somewhat unintuitive) friend.

0

Not sure if it is the 10.7.5 but on 10.9.5 it works just fine with iTunes v.12.0.1.

Select/Open a album click to play first or any song in it, select shuffle if you want to and it plays all songs in that album.

While showing what is up Next:

album

To make sure it only plays a single album select all songs in that album and hit play. Hold shift key click on first and last song that you want to play.

just album

  • But it them also plays more - how do you select just the album – Mark Dec 20 '14 at 22:59
  • Only select all songs in the album "all at once" the hit play. Now it should stop after completing playing the selected songs. – Ruskes Dec 20 '14 at 23:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .