I created a Yosemite boot USB, from the App Store version 10.10.1.

When I hold option during Boot, the USB drive doesn't show up on the menu.

I have an aluminium MBP, bought in 2009. It is the full body aluminium with the Superdrive.

Per Apple, this is my machine:

MacBook Pro (13-inch, Mid 2009)

The only drives I see when holding down option are Macintosh HD and Recovery. When I try to run recovery, it runs for a little and then goes to a "no" symbol, with the spinner still spinning. I am concerned that the HD may be dead/dying, but I don't want to jump to that conclusion yet.

How do I either boot to my USB, or just get a restore done?

I have already successfully backed up my files. I just want to restore the machine.

Edit 1

I made the USB Boot drive from this guide:


Specifically choice number 1, where I downloaded the OS from the App Store and ran the terminal commands on a pre-formatted USB drive.

Edit 2

Below you will see the Disk Utility for the USB drive. Not sure how to tell if it is a Boot disk or not.

Disk Utility on USB Boot Disk

Edit 3

The below screenshot shows EFI in Debug mode in Disk Utility.

Disk Utility Debug Mode with EFI

For what it's worth, when I plug in this drive into my working MBP, I see the "Install OS X Yosemite" get mounted in Finder.

Edit 4

Here is a screenshot of the "Startup Disk" option within "System Preferences" on my working MBP that has the Bootable USB plugged in - which proves that it was properly created, I believe. You can check the screenshot to confirm though.

Startup Disk Screen on Working MBP

Edit 5

Output from bless --info... command:

$ bless --info /Volumes/Install\ OS\ X\ Yosemite/
finderinfo[0]:    597 => Blessed System Folder is /Volumes/Install OS X Yosemite/.IABootFiles
finderinfo[1]:    615 => Blessed System File is /Volumes/Install OS X Yosemite/.IABootFiles/boot.efi
finderinfo[2]:      0 => Open-folder linked list empty
finderinfo[3]:      0 => No alternate OS blessed file/folder
finderinfo[4]:      0 => Unused field unset
finderinfo[5]:    597 => OS X blessed folder is /Volumes/Install OS X Yosemite/.IABootFiles
64-bit VSDB volume id:  0xA76212D6C7E30EC3
  • Press and hold the Option (⌥) key immediately upon hearing the startup chime. Release the key after Startup Manager appears. Startup Manager will scan and list connected drives and volumes that can be booted from Commented Nov 8, 2016 at 11:19
  • 1
    For anyone new who stumbled upon this question: Apple now provides a script to create a bootable media. The following instructions worked well for me: support.apple.com/en-us/HT201372
    – sdevikar
    Commented Mar 7, 2020 at 20:26

5 Answers 5


You might try resetting the pram on your mac. I understand that startup disk settings are stored there.

If the disk is bootable on other Macs, it stands to reason that it should boot on this one.

You can reset the pram by doing the following:

  1. Shut down the Mac.
  2. Locate the following four keys: option, command, p and r. You'll need them in the next step.
  3. Power on the Mac, then immediately hold option, command, p and r. You need to do this before the grey screen appears.
  4. Hold down the keys until you hear the startup sound twice, then release them.
  5. Plug in the bootable USB stick, restart the Mac, and hold option.

I can't guarantee that it'll work, but it won't hurt, so it's worth a try.

  • 3
    I'm having the same problem on a macbook 2,1. I tried the method with four keys combination and changing installation file, but it didn't work for me. What else can i try?
    – user122666
    Commented Apr 19, 2015 at 19:41
  • 1
    I owe you a beer now :D
    – shrekuu
    Commented Apr 20, 2016 at 2:55
  • I was using USB 3 and switching to an older stick (USB 2) did the trick for me. Commented Feb 17, 2022 at 14:04
  • Huge +1. I followed Apple's guide to reset my 2015 MB Pro to factory settings. However, there was some failure whenever I tried to re-install Sierra or Mojave from recovery mode (trying all three Cmd+* options). I tried a bootable drive from a memory stick with Mojave, but it would not show up on boot using Option. Apple mentions resetting PRAM after installing the new OS, not before. However, upon stumbling upon this, I gave it a shot and then, using the Cmd + Option + R on startup, I could install Mojave from internet recovery. I suspect FUSE from my previous install may have caused this.
    – mattkgross
    Commented Nov 30, 2023 at 16:06

I just ran into this as well. When booting from a USB disk that seemed to be bootable, it would display a "no" symbol ( e.g. ⃠ ...) after trying to boot into it and would then boot into the OS. I tried wulfderay's suggestion (the currently voted answer) to reset the pram and it didn't help.

I came across this installation tutorial and figured out that #5 in Step 1 of creating the drive had been wrong in my case. It's important to create the partition as "GUID Partition Table" rather than either of the other two. Mine was previously "Master Boot Record" as a partition scheme.

I'm guessing this could be the edge case that a few of us have run into. I confirmed the SHA of my Yosemite download and used the same one to re-create the bootable USB, so this was the only difference.

  • That #5 in Step 1 makes the difference if your mac can load the usb drive. Commented Oct 7, 2016 at 18:28
  • This is what I needed to do. It was bootable from my more recent macbook pro but not from my 2012 macbook air. After repartitioning and setting up the drive again, I could boot to it by choosing a boot drive from inside disk utility in recovery mode. (holding option key wasn't working for me)
    – Ryan Silva
    Commented Oct 19, 2017 at 23:37

After booting with the Option method, plug in the USB drive after the existing disks appear. I think this relates to protecting the system from USB viruses: you're normally only allowed to connect the drive after the system is powered-on... this is my logic anyway!

  • SO simple. This did it for me. Thanks! Commented Mar 11, 2022 at 22:37
  • This solved it for me.
    – RJM
    Commented Feb 18, 2023 at 18:37
  • Wow, this also sorted my issues with a 2014 Mac mini. Been tearing my hair out. > <
    – artaxerxes
    Commented Apr 30, 2023 at 14:20

Something similar has occurred to me before but then I identified that the .dmg of the OS X file was damaged which made the created bootable USB useless. Please make sure you check the SHA1 hash of the downloaded dmg with someone else to rule this possibility out.

  • If the DMG were damaged, would the info I put under Edits 3 - 5 be applicable? I assume that those are showing correct info under an undamaged DMG right? Commented Dec 24, 2014 at 20:48

Only thing that worked for me was to create the same Yosemite boot disk on a firewire drive.

MacPro Desktop Tower: OS X v10.9.5; 2x3.2GHz Quad Core Intel Xeon, 14GM 800 MHz DDR2, MacPro3,1.

  • 1
    I've never been able to get any Mac Pro to boot from USB; either DVD or put a temporary drive in [faster than USB & I don't have a Firewire enclosure]
    – Tetsujin
    Commented Sep 30, 2015 at 7:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .