13

Preview, by default, persists edits to the underlying file immediately. (i.e. if you crop something, the underlying file becomes cropped). I find this behavior very irritating.

I tried enabling Settings->General->"Ask to keep changes when closing documents". With this, Preview still persists the change to disk, but asks if I want to keep the change when I close the app.

A 2012 answer to a similar question suggested

defaults write -app 'preview' ApplePersistence -bool no

This does not seem to have any effect.

Is there any way to make Preview behave like a normal application? I want my changes unsaved and transient until I specifically hit save.

  • 1
    It still works on 10.9.5 so it must be the Yosemite thing. – Ruskes Dec 18 '14 at 4:19
  • try this, it is a far fetch but > System Preferences, iCloud, uncheck Documents & Data – Ruskes Dec 18 '14 at 4:26
  • 1
    I should never have upgraded to yosemite. Wifi issues and a constant fight against their doohickeys. Maybe I should go back to Mavericks. – Isaac Dec 18 '14 at 20:04
  • @Buscar웃 I don't see "Documents and Data". i.imgur.com/f0g1rFC.png – Isaac Dec 18 '14 at 20:04
  • Not even if you scroll down :) as for Yosemite, I am still not on it! guess why :), just sign out from iCloud for now. As I said it is far fetch, but I read somewhere that Yosemite is automatically saving your incomplete files to iCloud. – Ruskes Dec 18 '14 at 20:07
8

Per Turning Off Auto Saving In TextEdit And Other Mac Apps on the "Mac Tricks and Tips" website:

  1. Open System Preferences
  2. Go to "General"
  3. Enable "Ask to keep changes when closing documents"
| improve this answer | |
  • 1
    Thanks for the answer. Please add more information that you posted in the link as if the link dies, the answer will lose it's value – John K Nov 7 '15 at 9:41
1

While working with doc in Preview, hit the title bar of the doc and set its status to 'Locked'. This will lock the doc in Finder. If you'll try to edit it while it's locked, then system will propose to you to Duplicate the file so you can work with the copy.

Generally speaking they disabled this functionality in Yosemite since if you want to preserve original doc, you can easily create its copy and work with the copy. In all other cases docs are being autosaved as it is of great help to many other users.

Preview menu

| improve this answer | |
  • Extra manual effort on every file. Computers are supposed to do stuff for us! – benwiggy Jul 8 '19 at 13:39
0

Sadly, the ApplePersistence preference no longer works in Mojave and later. The only option is to disable Auto-saving in ALL applications, in System Preferences > General. This may not be desirable.

If you really want a PDF viewer that does explicit saves (or is entirely read-only), then you need to use a different application.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .