2

Sometimes when I press and release the CTRL key while my cursor is in a text field, the letter "I" gets inserted and an autosuggest list gets opened.

enter image description here

I really really dislike this because I often press and release the CTRL key without wanting to type anything.

How can I disable this functionality?

  • Do you have CTRL mapped to also do Escape when pressed and released? – 0942v8653 Dec 16 '14 at 22:36
  • No. The only keyboard item I have changed is mapping Caps Lock to Escape using Karabiner. – Cory Klein Dec 17 '14 at 19:16
  • @CoryKlien: Do you have Caps Lock mapped to Control with Seil or System Preferences? It's possible that you actually have CTRL mapped to both CTRL and Escape, then Caps mapped to CTRL.. – 0942v8653 Dec 18 '14 at 18:34
  • Turns out I actually did have CTRL mapped to Escape in Karabiner, somehow I missed it before! It was only mapped to Escape if I pressed and released CTRL without hitting any other buttons. – Cory Klein Dec 19 '14 at 19:03
1

As noted in another answer:

It's the auto completion from the built in spell checker and after a lengthy search I found the solution in Apples Discussion Forums:

defaults write -g NSUseSpellCheckerForCompletions -bool false

Afterwards restart affected programs and Esc just cancels searches again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .