This seems to be rather hit & miss, but often a link posted on SE leading to
support.apple.com/kb/[reference code]
seems to just give a blank page, as though it neither loads nor times out.

Sometimes a refresh will load it correctly, sometimes not.

Is there any workaround to this issue?

Edit: I've tried the Remove all website data suggestion, which worked for about 2 days, so I'm back to the manual 'cut the kb number, paste it into the main page' method.

  • 1
    Are you seeing this on iOS at all or just OS X?
    – bmike
    Dec 28, 2014 at 10:52
  • 1
    I'm not seeing it on just the few I've tested, but the same links are working fine on the Mac right now, too - I just tried some side by side, which in itself might spoil the results, hard to tell. I'll have to keep an eye on it
    – Tetsujin
    Dec 28, 2014 at 10:58

2 Answers 2


Update May 2019
There was recently a Meta question on this - Changing Apple links depending on region which concludes that, whilst support.apple.com/kb/[reference code] is the correct way to link these, caching/cookies sometimes upsets it & it turns out that removing kb/ entirely seems to fix it, leaving support.apple.com/[reference code] rather than any country or generic code at all as the simplest & potentially most reliable method.

Previous answer below

I've found the simplest workaround is to clear back the URL to just http://support.apple.com/kb/
This will then usually quickly redirect to your own country, at the entry to the support portal.

Then simply paste the KB article code into the search at the top right of the page, et voilà.

enter image description here

enter image description here

  • 1
    grrr.. bad cookies - I wish there were a better way to link here. Thanks for posting this to help out.
    – bmike
    Dec 28, 2014 at 10:51
  • I run into the problem most often with links found by Google searches. If you look at the page source for the "blank" page, it's horribly mangled, with <head> sections inside the body and html source following </html>. But I came up with the same solution as @Testujin: go to Apple Support and search for the article by number.
    – ganbustein
    Jan 11, 2015 at 10:07
  • I get it mainly from SE links, whether they contain a country code in the URL or not. There seems to be some internal argument as to which 'country' it should go to by default. I have more trouble if they are specifically cast to go to the /us/ site than if it's left generic - my own country is /gb/
    – Tetsujin
    Jan 11, 2015 at 10:22
  • 1
    There is Safari extension called UTM Stripper that may be of help, designed to give you direct links without all the crap Google and Google News adds.
    – Zo219
    Jan 16, 2015 at 1:54
  • I'll give that a go anyway, just for its primary task which always irritates me, but I don't think it would help in this case as there's really no 'garbage' in the urls, just a simple country code in the middle, or even often no country code at all; still gives the same issue on occasion.
    – Tetsujin
    Jan 16, 2015 at 7:48

I faced the same issue and I solve it (for a while at least) by deleting Apple website data from Safari.

Go to Preferences → Privacy and found a button called Detail... under Remove All Website Data...

In the search field type apple and delete all entries.

After that should work fine.

  • I'll try that - & see how long it lasts… sometimes I don't see it happen for days/weeks, then just out of the blue one will stick. Usually if I clear back the URL & go the long way round, I get no further issues for a while.
    – Tetsujin
    Dec 16, 2014 at 15:43
  • hmm… the trouble with that method is that it cleared a lot of other data I expected Safari to remember for me - though other than that it appears to be still working so far.
    – Tetsujin
    Dec 18, 2014 at 17:50
  • Doesn't work for me.
    – orome
    May 28, 2021 at 12:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .