2

Did Yosemite eliminate the Menubar icon for Messages? I don't see any preference to turn it back on. I found an Apple KB article that seems like it would offer the answer, but always results in a blank page.

http://support.apple.com/kb/PH15045

The irony is that I always previously disabled it, but the continuity features in iOS 8 and Yosemite have made Messages appealing to me for the very first time.

Thanks.

Update: Thanks to @Tetsujin I was able to see the KB article, but apparently something is different about my preferences since I don't see the option described.

enter image description here

  • Do you mean Yosemite? Because Continuity was introduced in OS X Yosemite. – Behdad Dec 16 '14 at 15:03
  • Oh geez, I really did. Man is that embarrassing. Thanks. – grovberg Dec 16 '14 at 15:07
  • btw, if you mean the kb article never resolves, it seems quite commong. Workaround is to clear the URL back to just support.apple.com/kb or alternatively apple.com/support [they will often auto-resolve to your own country] then add the KB id into the search, top right – Tetsujin Dec 16 '14 at 15:14
1

You have to enable Bonjour or AOL IM or another service to get that option to pop up.

| improve this answer | |
  • I don't know why this got a downvote because it appears to be the correct answer (and StackExchange won't let me upvote yet). Enabling Bonjour messaging made the option re-appear under Preferences > General. Disabling Bonjour both hid the option and disabled the menubar icon. Thanks! – grovberg Feb 24 '15 at 21:46
  • Weirdly that is the answer to the problem. Apple's support article about enabling the Messages menu bar icon does not mention the requirement for enabling Bonjour. I had disabled Bonjour Messaging since I never use it, and I consider any unused network service to be a potential security problem. – Lee Joramo Sep 8 '15 at 15:14
0

From the page You linked (works for Yosemite as well):

Messages (Mavericks): Add Messages to the menu bar

  1. Choose Messages > Preferences, then click General.
  2. Select “Show status in menu bar.” The Messages status menu appears in the menu bar as enter image description here
  3. Click the Messages icon in the menu bar, then choose an option from the menu:

    • To set the status of all your active accounts, choose a status from the menu.
    • To send a message to an available buddy using an active account, choose a buddy from the menu.
    • To show available Bonjour buddies in the menu, choose Display Bonjour Buddies.
| improve this answer | |
  • So then perhaps my installation is broken because I don't see that under General (I have in previous versions). cl.ly/YzU9 – grovberg Dec 16 '14 at 15:35
  • Unfortunately I have polish version of OS X, so it might not be very helpful to paste the screenshot here. I have Yosemite and it's 4th checkbox from the bottom in General tab... – Mateusz Szlosek Dec 16 '14 at 15:39
  • Hm, I see that others might have the same preferences panel as You: tekrevue.com/tip/customize-messages-font-yosemite . That's strange. What Messages version You have? Mine is: 8.0 (4725) and additionaly I have Audio/Video tab in preferences. – Mateusz Szlosek Dec 16 '14 at 15:47
  • What version of Adium.app are you running? – tron_jones Dec 16 '14 at 16:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .