Ok guys, here's the deal. Randomly, I wasn't doing anything specific -- my system starts getting sluggish. I checked the activity viewer -- wow, finder is at 150% CPU!

I have scoured the internet for fixes, and franky, I have tried them all (except one -- which I may need help with -- more on that later).

SYSTEM: Snow Leopard with a Mac Pro (Twelve Core 2.66 Westmere)

This is what I have tried and the results:

Trashing com.apple.finder.plist, com.apple.systemuiserver.plist, com.apple.loginwindow.plist. -- NO FIX
Trashing ALL apple.* namespaced .plist files -- NO FIX
Turning off "calculate all sizes" in finder -- NO FIX
Turning off "show view options" in finder -- NO FIX
Disabling all startup items -- NO FIX
Unplugging external hard drives -- NO FIX
Getting rid of all data on desktop. -- NO FIX

However, if I create a new account or use my wife's account -- the FINDER CPU USAGE IS NORMAL.

I analyzed the finders cpu pattern, it goes like this. If active, its always between 70 and 150% cpu usage. If i kill it, and stay 100% idle -- it goes from 0-ish% to 100+% slowly, and the Real Memory column in activity viewer goes from 0mb to ~2gb+ slowly, and when it gets around there, it dies and cycles all over again.

Here's where I need help from people smarter than me in this area. What are some methods I can use to trace what's happening in Finder?

I am pretty new to Mac and this has been a big blow to me -- I am loving the rest of it after being on Windows for over 17 years.

Would appreciate any help I can get!

I am getting the following when I issue the fs-usage -f filesys

18:03:19 getdirentries64 0.000401 W Path Finder
18:03:19 getdirentries64 0.000404 W Path Finder
18:03:19 getdirentries64 0.000340 W Path Finder
18:03:19 getdirentries64 0.000339 W Path Finder
18:03:19 getdirentries64 0.000535 W Finder
18:03:19 getdirentries64 0.000192 W Path Finder
18:03:19 getdirentries64 0.000326 W Path Finder
18:03:19 getdirentries64 0.000462 W Path Finder
18:03:19 getdirentries64 0.000194 W Path Finder
18:03:19 getdirentries64 0.000127 W Path Finder
18:03:19 getdirentries64 0.000410 W Finder
18:03:19 getdirentries64 0.000198 W Path Finder
18:03:19 getdirentries64 0.000600 W Path Finder
18:03:19 getdirentries64 0.000188 W Finder
18:03:19 getdirentries64 0.001019 W Finder
18:03:19 getdirentries64 0.000416 W Path Finder

Any ideas? I disabled path finder after and it still happens, but with just Finder.

  • 2
    hmmm. saw this on superuser. must have been cross-posted
    – user6124
    Jun 20, 2011 at 14:39
  • Three things that caused similar 100% CPU usage for me in the past: 1. Time Machine backup (after a long time. May happen if you backup to n external drive that is no always connected), 2. QuickSilver (I had it once when I upgraded and one other time) and 3. Firefox. (Of these TimeMachine and QuickSilver may be running in the background)
    – Nivas
    Jun 21, 2011 at 11:25
  • anything what will say, is pure guessing. Check my answer for updates.
    – jm666
    Jun 21, 2011 at 22:14
  • 'Turning off "show view options" in finder' is not so simple. One must turn it off for each open folder that has it on.
    – user14335
    Nov 30, 2011 at 0:07

6 Answers 6



  • consult the Utilities -> Console.app and check your logfiles, for some idea. ;)


  • Activity Monitor (also in Utilities) may help shed some light and can tell you what code Finder is busy with and what else is happening at the same time.

    1. Look over the routines when you sample the Finder to see if they make any sense (or at least Finder gets caught in the same code each time to know you have one cause and not many)
    2. What processes are also getting CPU when this happens?
    3. Does this happen when all networks are disconnected?
    4. Are disk activity and network levels higher or lower than normal when this happens?

If Console does not help, you can trace all the network and file usage to see if you can snoop at what Finder and the system is doing:

  • open Terminal.app
  • in its preferences change the scroll-back buffer to 10.000+ lines
  • and enter the next command
  • sudo fs_usage #you will need enter the admin password
  • after a while (10-20 seconds) you can interrupt with CTRL+c
  • now scroll back and try get some idea - i understand than it is hard, because you will got hundreds lines what are normal...

This will show what files are currently used in the whole OS - maybe you will get some idea, what's happening.


  • HDD error in several sectors - (try check smart-status for your HDD)
  • bad QuickLook plugin?
  • remote HDD (iDisk?) timeouts?


First - if your wife's account is OK - thats can mean,

  1. the problem is "somewhere" bellow your $HOME dir, so it is probably not in /System or /Library, or
  2. the problem is "somewhere" in /System or /Library, but caused by your login (StartupItem or LaunchDaemon or some your Preference setting what use Finder for some work - for example TimeMachine)

Some guessing (but honestly - these are not "advices" only pure guessing)

  • uninstall PathFinder.

  • check $HOME/Library/QuickLook folder. if anything is here, try move into ~/Desktop (for temporary) and relog - if not help, move them back - your should relog when moving plugins.

  • check /Library/QuickLook (let there here only QBQL.., iWork) - don't trash them, only temporary move to desktop and relog.

  • do you installed any Finder-plugin/hack - something?

  • try disable TimeMachine - if it is enabled

  • try eject (umount) all networked drives, and usb drives

  • have you BootCamp especially with NTFS? - Try exclude it from Spotlight, TimeMachine etc...

  • try exclude everything from Spotlight (this probably will not help, but for "sure" - your mdworder should stop indexing) (in the SysytemPrefs -> Spotlight -> Privacy - add your whole hdd and bootcamp too.)

  • disable all sharing (SysPrefs->Sharing)

  • download Onyx and remove all Caches. (this will cause increased CPU usage while rebuild cache again, but only for short time)

  • remove ALL .DS_Store (hidden) files - don't worry, they're not essential. Sure exists some GUI tool for this job. If don't find any, you can try this Terminal command.

    find "$HOME" -name .DS_Store -print0 | xargs -0 echo

the above is for "dry run" - you can check what will be removed, if satisfied, change the echo to rm

  • if none of above help (and probably will not :=() have no idea...

bmike? any other idea?

  • 1
    I would add to this good list, sample finder when it is running poorly using activity monitor. What processes are also getting CPU when this happens? Does this happen when all networks are disconnected? what are the disk activity and network levels when this happens? All of these will help narrow down the cause. Once it's narrow, the cure is easily evident.
    – bmike
    Jun 20, 2011 at 16:40
  • Yeah, you're right! I'm forgot the sampling. Great comment :)
    – jm666
    Jun 20, 2011 at 16:49
  • thanks so much for the suggestions! i cant wait to get home from work to try them out! will keep everyone posted -- much thanks. Jun 20, 2011 at 17:50

I have deleted the com.apple.finder.plist, restarted AND unchecked "Calculate all sizes" in View->Show View Options AND pressed "Use as Default". It helped me so far.

Finder was at 70-100% CPU time before; "sudo fs_usage" showed a lot of "attrlist" calls on various files, it looked like it is reindexing something. I left it for the whole night, but nothing changed. My version is that yesterday I have cleaned up a lot in my iTunes, deleted a lot of small files and that triggered recalculating in Finder. Just my guess.


A short form would be opening terminal and executing:

top -ocpu

This will show you the processes running and list them by processor usage. You will see terminal/top pop up to the top on occasion while it is running. But this will give you an idea what it may be.

Typical culprits: Spotlight indexing Address Book/calendaring sync Some rogue process or browser plugin.

See if this helps the next time you see as system slowdown.


this is ONLY the finder taking all the CPU time, so none of those solutions will work... especially looking for the CPU hog, because the finder itself is the CPU hog when it goes rouge. (starting up and having no other apps or processes running except system processes, and seeing that spotlight is not indexing, and timemachine is not backing up.)

what worked for me is to delete the com.apple.finder.plist file in the /(put your user name here)/library/preferences/ folder... then restarting. (most likely because something went wrong with moving a file around in some window or desktop, like now some file is off screen or on a secondary screen but feels the need to be on the first screen)

this i am pretty sure is what the OP was experiencing too.. (also this problem will return if you open the offending window with some file in it that is rouge (off screen) or simply way too many files in the window)

if your desktop is cluttered with dozens of files, this will also bring the problem around again.

  • 1
    The originator states that they tried discarding the Finder preferences file.
    – bneely
    Feb 4, 2012 at 12:39

I had the 100% cpu usage issue at different times. Started writing the times the I got it, and checked the task scheduler on what jobs ran at the time. In my case there was a check on the back up job 5 minutes each time i logged in or unlocked the screen saver, and it was marked as a high prioirty job. For the moment I only changed the prioirty since i am not sure if the job is needed. Now the computer is much more usable .


Deleting the ~/Library/Preferences/com.apple.finder.plist file worked for me when I had this very same problem.

  • except he said this was the first thing he tried...
    – MattDMo
    Jan 17, 2013 at 23:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .