2

I have a WD external hard drive. I've been running the routine tests to make sure all my stuff is safe lately. In Disk Utility, I did Verify Disk on both the disk itself as well as the main partition, which is in the encrypted HD format.

I ran across this error on the partition:

Invalid Disk Label @[number] cksum mismatch

Which didn't seem very good. Resources online have close to no information, and I don't know what this is. It went away after I scanned again, but that is a common occurrence and other posters said that I should keep an eye on it.

I ran Repair Disk and it went without a hitch, but Verify Disk after that still showed the error.

I ran SMART Utility with the SAT-SMART Driver to enable SMART on external USB drives, it passed with 0 bad sectors and stuff.

Any ideas?

MacBook Air - Mavericks 10.9.5

  • Saw that, but this is on normal use on Mavericks (not after upgrade), and not on the main hard drive but an external. Updated description to add Mavericks. – yotero Dec 15 '14 at 19:28
  • I can find a lot of refs on Google, back to Lion - not one seems to have a happy ending for the drive in question. I'd be seriously tempted to back it up/clone to another drive & then see if it can be fixed, rather than the other way round – Tetsujin Dec 15 '14 at 19:44
  • Thanks for taking the time to look @Tetsujin! Thing is, this drive is also mirrored to another drive but ... that drive also has the same exact problem. I'm starting to think it's a certain file that is causing the checksum mismatch. – yotero Dec 15 '14 at 20:01
  • Possibly. It's not an error i actually can find the true cause of; maybe a workaround would be file-copy rather than 'clone'. I'm really not sure, sorry. – Tetsujin Dec 15 '14 at 20:05
  • @yotero Is your external device a RAID? – klanomath Dec 15 '14 at 20:10

You must log in to answer this question.

Browse other questions tagged .