1

I have a Mac Mini that's a few years old.

I'd like to use it for watching online video, because it's small, we're not using it for anything else, it fits nicely under the TV, and I can connect its video output to the TV. We've got a month's free trial of Amazon Prime Video.

It's 32-bit (Intel Core Duo) so it's running Mac OS X Snow Leopard (version 10.6), which I understand is the most recent version of OS X that it's possible to upgrade it to. It has 1Gb of ram.

I've upgraded Flash and downloaded Silverlight and although APV videos won't play on Chrome, they will play on Firefox. Which is ok.

But when I play them back I get stuttering. :( Sometimes it's ok for a minute or 2 and then we get a little stutter, other times its stuttering every 10 seconds. It seems to stutter mostly when there's a big change in the image and lots happening in the audio - that could be my imagination.

To give video playback the highest priority (the machine is not being used for anything else), I did a renice -20 pid for the Firefox process and for the Silverlight process which it spawned. That didn't seem to help.

I know that the problem is with this machine (rather than with our internet connection or our router) because I've tried watching the videos on my laptop, connected to the internet in the same way, and that works well.

I've rebooted the machine and I've made sure there's only 1 logged-in user.

Can you suggest things I could try in order to make Amazon Prime Video play back without stuttering? Thanks!

sh-3.2# system_profiler SPHardwareDataType
Hardware:

Hardware Overview:

  Model Name: Mac mini
  Model Identifier: Macmini1,1
  Processor Name: Intel Core Duo
  Processor Speed: 1.66 GHz
  Number Of Processors: 1
  Total Number Of Cores: 2
  L2 Cache: 2 MB
  Memory: 1 GB
  Bus Speed: 667 MHz
  Boot ROM Version: MM11.0055.B08
  SMC Version (system): 1.3f4
  Serial Number (system): VM65001EW0C
  Hardware UUID: 00000000-0000-1000-8000-0016CBA7861B
  • 1
    Could you edit in what system_profiler SPHardwareDataType shows for your few year old Mini? (omit the serial if you don't want that posted publicly) It's probably a long shot and you'll need to find a setting on Amazon to decrease the resolution of the video stream, but perhaps there's something that can be done with your older hardware and software. – bmike Dec 15 '14 at 16:20
  • 1
    Perfect. I could give you an answer how to determine if the CPU is the limiting factor, which would be my guess that the video stream just is too much for the CPU to process. – bmike Dec 15 '14 at 16:51
  • 1
    @bmike, yeah, the CPU is showing 120% usage - i.e. one core is maxed out - during playback. I've just discovered this help page amazon.co.uk/gp/help/customer/… so I'm going to try the recommendations there too. The little fella is almost doing it! Just needs a bit of help. :) – A E Dec 15 '14 at 16:52
  • @bmike, I've updated the question with that info – A E Dec 15 '14 at 20:53
1

My guess is that your CPU just isn't up to the task of decoding the stream of data that makes up the video stream for several reasons.

  1. Amazon video is using a somewhat inefficient codec and software stack to deliver the content.
  2. The software to render the video is likely single threaded on your Mac OS.
  3. Your CPU has only two cores and at 1.66 GHz of that era isn't keeping up.
  4. Your desktop size is too large and/or you can't ask the video server to send a smaller picture that can be processed. Each time you double the sides of a rectangle, you have to calculate 4x the pixels. Even reducing from 1080 horizontal pixels to 720 horizontal pixels would drastically reduce the processing power needed to render the video.

You can verify that the CPU is indeed the culprit by rebooting your Mac and opening only the Activity Monitor app and watching the CPU graph. Set the update interval to be 5 seconds in the app and then open your web browser of choice to an empty page. Again, let the CPU settle. Lastly, load the video you want and then pause the stream.

Looking at the CPU load at that point will let you know if any other process is hitting the CPU in a meaningful way. Anything over 5% would be worrisome from a maximum performance standpoint.

Then let the video play and watch the CPU allocation.

Knowing that the CPU is the problem, you can try reducing the screen resolution or putting the browser on an external display VGA or reducing the color depth of the main display might all help or hurt CPU load - so running some controlled tests might get you to acceptable settings. If not, you could get a secondhand iPod touch or iPhone/iPad and probably stream Amazon video inexpensively and far more smoothly than your Mac.

1

It turned out that switching a setting on Amazon's website from the Silverlight player to the Flash player solved the problem.

For anyone else with the same problem the setting is on this page: http://www.amazon.co.uk/gp/help/customer/display.html?nodeId=201460940&encoding=UTF8&ref=atv_pc_pp_more

Thank you @bmike for your advice nonetheless!

  • 1
    Now this is an awesome answer. I just had some ideas on how to troubleshoot it and no real insight into how to fix things. Thanks for sharing and be sure to accept this once the wait period expires for self accepting an answer. – bmike Dec 16 '14 at 2:43
  • Thanks @bmike but I'm kind of embarrassed that the solution turned out to be so simple! I feel a bit silly. :( – A E Dec 16 '14 at 12:11
  • Flash no longer seems to be an option for Amazon Prime. :P – user3932000 Dec 29 '15 at 21:20
1

I just experienced the same issue for the past week on a mid-2012 quad-core MBPr w/ 16 GB ram.

Turns out it was caused by a program called Memory Monitor. After disabling this program the issue stopped and I get smooth video playback.

Update: After more observation it appears to be a memory issue. If I spin up a Parallels VM the stutter comes back, but less intense than when Memory Monitor was running.

My conclusion at this point is I'm running out of memory (somehow!). Memory Monitor's reorganization of the system's memory just exasperated the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .