3

I use an iPhone 4s, with iOS 7.1.2

I have two keyboards installed. The first is British and the second is Emoji.

When I tap the globe button it switches to emoji. When I tap it again it switches back to qwerty but the space bar will flash the text "English (US)" which then fades to the word "space". Tapping the 123 button in qwerty mode shows a £ sign; I have to tap the #+= button to show the € and $ signs.

The phone highlights colour as wrong, but not color. I want to force British English spelling.

How can force the phone to use a UK keyboard? How can I force the phone to only use British English spellings?

5

You need to set your device language to English (U.K.), not just the keyboard. To do this:

  1. Open Settings
  2. Tap "General"
  3. Tap "Language & Region"
  4. Tap "iPhone Language"
  5. Select "English (U.K.)"

Your iPhone should reboot and your dictionary should be set to British English. If it doesn't, you may need to reset your dictionary by:

  1. Open Settings
  2. Tap "General"
  3. Scroll to the bottom and tap "Reset"
  4. Tap "Reset Keyboard Dictionary"

You can verify that you are running your iPhone with British English as your preferred language as in the main Settings menu you will see an option labelled "Mobile" (it is labelled "Cellular" in US English).

4

In Settings → General → Language & Region → Preferred Language Order, you have to select English (U.K.) and remove others.

In Settings → General → Keyboard → Keyboards you can select the keyboards languages you want. There is a keyboard called English (UK).

0

You can also just hold the globe button down and choose UK English there.

0

iPhone 8 Remove and add languages under keyboards. This will give access to the appropriate spelling correction.

image

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .