I have migrated to Mac OS X 10.10 Yosemite. Sometimes I use an 'on my mac' calendar. I just wanted to create one for one of my projects, but I can only see "Exchange", "google" and "iCloud" but I don't want any of those, just a local one.

The menu item is not there anymore. What setting am I missing?

  • 1
    Does right click on the sidebar with calendars and choosing "New Calendar" is what You're asking? I'm not sure I understand the question. Commented Dec 15, 2014 at 15:04
  • I go to "File"->"New Calendar" -> "...". There used to be an "On my computer" item. but I only see iCloud, Google or exchange there... In the calendar sidebar there is no "on my mac" section..
    – ilya
    Commented Dec 15, 2014 at 15:12
  • 2
    Do You have any calendar under "Other" category? If Yes try selecting it and then right click on sidebar and choose New Calendar. I can create local (on my mac) calendar with this method. Commented Dec 15, 2014 at 15:16
  • WOW, yes.. it appeared. And now I also have the menu item under new...
    – ilya
    Commented Dec 15, 2014 at 15:46

6 Answers 6


To create local calendar on Yosemite (when no such option is available via File menu) navigate to calendar in Other section in the sidebar, select one and right click, then select New Calendar. This should create calendar in On My Mac section (local).

  • 2
    As referenced in Steve Moser's reply below, you may need to hide other calendar groups before this menu item appears. I had to collapse them all then right-click in the gray empty area of the sidebar. Commented Sep 22, 2015 at 18:41
  • Don't right click, just select one of the other calendars, once expanded, and then from the menu when you create a calendar it'll become local.
    – John White
    Commented Jul 15, 2021 at 14:12

As an addendum to the above, if the Other section is not visible in the sidebar, go to Preferences and select the General icon.

Now select the Show Birthdays Calendar or Show Holidays Calendar (or both) and close the Preferences pane. The Other section is now added below the iCloud section.

You can now right-click in the Other section, select New Calendar and an untitled calendar is created in the On My Mac section above the iCloud section.

I find this very useful if I need an application to run at a specific time each day on one specific Mac and not on any others. This also prevents alerts from appearing on other devices such as iPhone or iPad where they would have no significance.


The other answers didn't work for me until I hid all the other calendar groups by hovering over them to show the hide button. Then I right clicked to create a new calendar.


Just had this problem with a new MacBook running Sierra. I tried disabling iCloud Calendars but as soon as it was enabled my local calendars were moved to iCloud.

Finally was able to do it, by selecting on of the calendars inside Other (i.e. Found in Apps) and then doing File -> New Calendar.

  • this simple "trick" works for me
    – elgcom
    Commented Apr 8, 2023 at 7:24

If you first turn off your iCloud account using the System Preferences control panel, an "On My Mac" option appears in the File > New Calendar menu. A new calendar can then be created under a new "On My Mac" group.


I got it to appear by disabling all the calendar accounts in the calendar preferences section, then re-enabling them

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .