6

I have an MBA running Yosemite. Apps like Mail, messages, calendar, and FaceTime have 'banner' notifications that pop up in my laptop's built-in display but they don't pop up on my external monitor that's plugged in via a thunderbolt adapter.

How can I get notifications to display on my active display?

Is this even possible or a feature that is yet to be implemented by Apple?

  • Is your external display set as your default display? Mine is, and my notifications always pop up on the external display. (Not sure about "active display" since my 27'' external display is the active one 99.9% of the time...) – 4ae1e1 Dec 15 '14 at 2:04
  • No the external display is not the default. Not sure even how to set that. I guess this would be the only and crude solution. Perhaps a feature Apple should implement. If I get an email while working and focusing on one screen and the notification pops up in the built-in I would never know if it weren't for the sound. – gh0st Dec 15 '14 at 2:08
  • By default display I actually mean primary display. How to set: support.apple.com/en-us/HT202780 (search for "primary display" in the support article). – 4ae1e1 Dec 15 '14 at 2:10
  • 1
    Not sure about this "feature". Showing up on the primary display should be good enough. Constantly switching displays for notifications will most likely be unreliable and lead to more complaints. It's your responsibility to set the most sensible primary display. – 4ae1e1 Dec 15 '14 at 2:12
8

Try this: System Preferences -> Displays and drag menubar (small white stripe at the top of the blue box in the "Arrangement" tab) to your external (attached) display. Built-in notifications will be displayed on the monitor with main menubar.

In addition to this you may wish to explore Growl app (http://growl.info/), which allows you to setup notifications in more sophisticated way and configure them for several displays.

  • fyi, the menu bar is the small white stripe at the top of the blue box in the "Arrangement" tab – nmat Nov 28 '16 at 11:31
4

Go to notifications and under the section "Turn on Do Not Disturb" toggle off, "When mirroring to TVs and projectors".enter image description here

  • That does not solve the problem, nor it should: when you have an external display like described in the question you're not "mirroring". – mcdado Jul 9 '16 at 22:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .