5

I am having a problem with the Dock popping up when I have my mouse near the bottom. Before, the Dock would pop up when the mouse was at the very bottom. But the current behavior makes it difficult to access things like tabs on a spreadsheet because the Dock comes up and covers them. What is to be done?

1
  • I only have the described behavior after upgrading to Big Sur. Your (old) post makes me think it may be something other than a new feature. What did you change before this behavior?
    – mvreijn
    Apr 19, 2021 at 20:16

2 Answers 2

3

Try following in Terminal to adjust the Dock behavior.

defaults write com.apple.dock autohide-time-modifier -float 0.5

compliment that with killall Dock to make it active.

The number at the end is in seconds (delay) so choose what it suits you.

To return to original settings use

defaults delete com.apple.Dock autohide-time-modifier
1
  • 2
    This just adjusts the delay, mut doesn't lower the distance threshold to show the dock.
    – ruohola
    Feb 8, 2021 at 18:24
1

My personal solution?

a) Put the dock on the side of the screen, not at the bottom. Screens are generally wider than they are tall, and documents are generally taller than they are wide. Screen real estate is much more precious at the bottom than at the sides.

b) Never let the dock hide. Having the dock hide is not useful, because the space it covers isn't really available for anything else, as you've noticed. A hidden dock entices you to put things in places on your screen that you cannot reach.

But that's just my opinion. Yours may vary, or course. But you did ask....

1
  • Thanks, ganbustein. I don't agree with your second point, though: I generally have the terminal on the left side, and the keyboard dont trigger the dock.
    – jonasfh
    Mar 12, 2021 at 8:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .