My teenage daughter's Mac Mini (running OSX 10.8) was cluttered with all sorts of stuff, even unwanted and inappropriate popup windows when using Safari, and more. So I made a final TM backup. Then I did a clean install of Mavericks.

Now, I wanted to bring back individual files and folders from that TM backup, BUT...

  • going to Migration Assistant, I realized that it would overwrite the clean install and bring back the clutter. This is no option.
  • going to TM, I realized I wasn't able to select any of the snapshots from the timeline
  • going to the external drive containing the TM backup with Finder, all folders within her "old" user-folder showed a small red stop-sign, which I learned is an issue with permissions. I wasn't able to restore manually.

What to do now?

I know I could restore the cluttered state and copy folders and files manually to an external drive, make another clean install of Mavericks, then copy manually from that external drive. This seems a lot of time and work to me.

Is there an easier way?

  • Does this answer to a similar question provide a solution? To see the Browse other Backup Disks alt+click the Time Machine icon in the menu bar. Commented Dec 16, 2014 at 23:36
  • Are the username and password on the clean install the same as the username and password before you wiped everything?
    – user24601
    Commented Dec 16, 2014 at 23:48
  • @michi how many accounts did the mac mini have previously?
    – klanomath
    Commented Dec 16, 2014 at 23:50
  • @michi And how many accounts does the mac mini have now?
    – klanomath
    Commented Dec 17, 2014 at 8:21
  • @BartArondson I am not in front of that MacMini at this moment. I don't remember seeing the "Browse other Backups" though, I tend to believe it wasn't there.
    – michi
    Commented Dec 17, 2014 at 16:44

6 Answers 6

  • going to the external drive containing the TM backup with Finder, all folders within her "old" user-folder showed a small red stop-sign, which I learned is an issue with permissions. I wasn't able to restore manually.

This is probably the easiest way to go.

You can fix the "red stop-sign" issue by opening Terminal and entering:

sudo diskutil disableOwnership /Volumes/[Your TM Drive].

You'll then be able to copy the files over manually, without having to worry about permissions.

  • will a full restore still be possible after this operation?
    – michi
    Commented Dec 22, 2014 at 21:40
  • > will a full restore still be possible after this operation? Yes, although you might need to re-enable permissions with: sudo diskutil disableOwnership /Volumes/[Your TM Drive]. > it worked! I would upvote your answer, if I just could ;-) I spent my rep on the bounty, and now I can't upvote Well, you could always award the bounty, and/or mark it as the right answer, if you feel like it solved your issue. ;) Commented Dec 23, 2014 at 7:32

If you look on that Time Machine drive you should see a top-level folder named Backups.backupdb. If you open that folder you will see a machine name folder, inside that a series of dated folders representing individual backup instances. Inside each of those you will find "Macintosh HD" or whatever your hard disk used to be called. In there, find your files!

Here's what one of mine looks like:

Time Machine folders

You will not necessarily find ever file at every date, so you should have some idea of when the last good backup of the file you want was made.

Files appear not to be encrypted* or compressed so it should be as simple as just dragging them back to where you want them. I was able to restore a text file this way.

*you may have set your Time Machine backup to be encrypted... in which case it should not be encrypted once you have entered the volume password. If it is encrypted in this way you won't see anything.

One final note - you may need to authenticate as the user who made the backup to access the files. So if restoring to an account with a different username or password, be prepared to provide the correct details.

  • Would this circumvent the going to the external drive containing the TM backup with Finder, all folders within her "old" user-folder showed a small red stop-sign... problem? Commented Dec 16, 2014 at 23:41
  • The stop sign is a permission issue. Is your current user an administrator? I would expect the OS to ask for an administrator's password, then allow access. If not, change the permissions - superuser.com/a/430044/39503 is a good answer. Commented Dec 16, 2014 at 23:45
  • @AdamEberbach I'll have to get back to that machine and try to authenticate with the old username and pw. And yes, current user is admin.
    – michi
    Commented Dec 17, 2014 at 16:47
  • If the drive is mounted, just use the chown command - "sudo chown -R <current username> *" in "/Volumes/<time machine drive name>" - no need to mess around with recreating users. Commented Dec 17, 2014 at 23:09

Your account has to have the same username as the pre-wipe account. Make a new account with the pre-wipe account's username, and you should be able to get your files without needing to authenticate every time!

(Thanks to 0942v8653 for saying that you only need the username. If it still doesn't work, try making the password the same too.)

  • You should only need the same username.
    – 0942v8653
    Commented Dec 17, 2014 at 17:15
  • @user24601 please add a source. AFAIR the same UserID is necessary and NOT the user name/password!
    – klanomath
    Commented Dec 17, 2014 at 17:29
  • Source: My own experience. The last time I had to authenticate was when I was trying to access files from a backup of an old laptop in which my username was "Student." I've never had to authenticate ever since getting a computer on which my username was my actual name (and I have tried quite a few times). I've always had the password be the same too, so I have no way of knowing whether or not the username is the only contributing factor.
    – user24601
    Commented Dec 17, 2014 at 17:31
  • The UID vs username issue might be different depending on if the time machine is in a sparse image or written directly. If written directly, I don't think the file system (wrt permissions) cares about names, only UIDs.
    – Kent
    Commented Dec 17, 2014 at 22:49

I have a late 2008 macbook pro and time capsule. I rebooted and renamed my hard drive years later. I wanted to recover my files manually. Doing so individually or all at once and put on another portable hard drive so I could pick and choose what I wanted to use in the future. Nothing would show up in Time Machine. And I also wasn’t sure how to copy large quantities at once.

  1. I plugged in the network cable to y laptop then the TC. Then power.

  2. I couldn’t figure out who to get into the bundle, so I found this and typed it in terminal. Change WHOEVER to your computer name.

hdiutil attach -noverify /Volumes/WHOEVER's-1/WHOEVER’s MacBook Pro.sparsebundle

  1. It was supposed to mount so I could peek inside without TM but it didn’t work.

  2. I also tried right-clicking on the bundle and ‘show package contents’. Then click on the Bands folder or whatever. Takes a while to load all the files.

  3. Not sure if that worked either. So I went in TM and this is what worked for me.

  1. Under the ‘Now’ state, I clicked on my WHOEVER’s Macbook Pro, in the left window pane.

  2. I clicked on my TC hard drive OR whatever you named yours.

  3. I clicked on the sparsebundle backup.

THIS IS WHERE TM’s LOGIC COMES IN TO PLACE. —You must have the sparsebundle selected AND THEN ‘GO BACK IN TIME’ by clicking the up arrow. This will effectively GO BACK to when that backup made sense, ie. 2012!…

  1. I click the up arrow to back in time only once. It took me to the most recent accomplished backup file.

  2. ONCE I was browsing in this window, I clicked on MACINTOSH HD. Then USERS. Then MY NAME. I looked around and was excited to see OLD FILES!! :)

  3. So this is where you want to be. I tested a couple files and the following worked for me: Right click on the folder you want to TRANSFER. Click on ‘RESTORE FILE TO…”

  4. This should take you out of TM. You will then be able to CHOOSE A FOLDER on your computer. I chose my attached portable hard drive (a lot of space).

  5. I chose to backup the entire MACINTOSH HD. IT TAKES A LONG TIME!! Choose your location and WALK AWAY. Come back in 30 minutes and you should see “20 GB of 500 GB - About 8 hours” or something.

I hope this helps!

  • Thank you for that impressive answer. I solved the problem in the meantime but will be back if needed
    – michi
    Commented Jan 8, 2016 at 15:43

The easiest thing by far is migrating and making a clean (non time machine) back up of your root or desktop file system. Time Machine is great but it makes what you are doing unnecessarily laborious. Though it takes a while to migrate and then copy and then reinstall a clean copy most of that time is passive work. So just set it and forget it or your going to end up spending as much time working on creating your solution as you are to implement it.

  • that's bad news :-( Fortunately, some other answers provide a way to go from the clean install without having to return to the old state first.
    – michi
    Commented Dec 23, 2014 at 1:16
  1. Download and install BatchMod
  2. Open the Users folder in the backup:


  3. Drag the user folder (in my example 'eva') to BatchMod:


  4. Modify the settings like in the picture above

  5. Hit Apply - you will be asked to enter your password. It may take a while to adjust the new permissions.
  6. Copy all needed files and folders to your new user folder
  • I would also "Clear xattrs" and "Clear ACLs". The time machine backup files have some attributes that make it difficult to delete if they are just copied without modificiation.
    – Kent
    Commented Dec 17, 2014 at 22:51
  • @Kent added in the pic, thanx
    – klanomath
    Commented Dec 17, 2014 at 23:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .