7

I am trying to transfer my existing (Early 2008) Mac Pro to a new (refurb) 2013 Mac Pro. I'm still in "setup assistant" mode.

The amount of information being transferred is about 120Gb. I've tried transferring over a direct-connected Ethernet from Mac-to-Mac, as well as a brand new Time Machine backup to an external SSD connected via a Thunderbolt 1 breakout box.

Every time I try to transfer, the transfer makes it to the applications stage in a reasonable amount of time. The progress bar is almost full. Then it starts doing the applications. At first, the screen shows "Transferring Applications"/"Transferring files to support applications" pretty fast. Then it starts getting slower. And slower. All the while, the completion time (which was "about a minute" starts creeping up.) The first time I let it run all night. By morning it was saying there would be over 250 hours to completion.

I've tried it 4 times since then (including a complete system reinstall), and the same thing happens every time.

I feel like I'm down to 2 scenarios:

  1. The Mac Pro has a hardware issue. I've already run the hardware diagnostics, but nothing shows up. That being said, this is a refurb, it's possible something is wrong that only affects the new machine during long transfers.

  2. There's something in the backup or my applications setup that's causing the migration to get stuck in a loop. I've looked on the system drive for a log, but I haven't found one.

Here's where it gets really, really bizarre: I can't find any sign of the files transferred on the new Mac after I've stopped it. Not a single file appears on "Macintosh HD" on the new Mac.

Any ideas? Apple can't help me in the store until Monday, so I thought I'd ask here.

  • +1, I am having the exact same issue. Did you try selecting to restore everything but applications, with the intention of re-installing all of your applications later on? I am debating about trying that. – ESultanik Mar 3 '15 at 14:34
  • @ESultanik No, but reinstalling the applications is pretty much the reason I didn't want to do a full reinstallation in the first place. I've been using the new Mac Pro with the TM restoration I explained below since I wrote this, and it's been working without serious issue. – OverZealous Mar 3 '15 at 14:37
1

Also not really an answer but more a practical approach.

Another idea that requires manual work. I did this with a Macbook Pro and a MacPro 2006:

  • Boot your old MacPro into Firewire Target Mode (yes this works with "T" on power on).
  • Connect it to you new MacPro with a FireWire cable.
  • Mount all harddiscs
  • Copy over all data you need, but leave out the Library folder in your old homedirectory.
  • Do a fresh install of your favourite software, that is quicker and safer that copying them from the old MacPro or a TimeMachine Backup. You will definitely miss important files. (just my experience with MS Office)

Positive effect of this: you trashed all old things you really do not need. :-)

I even go a step further - On my old MacPro I set all files and directories I want to copy on a red label in the finder. When mounting the harddiscs, I immediately see what is important and needs to be copied. :-) And as a reminder of which software I will need on the new machine, I set the finder label "green" to all applications I will need on my new machine.

0

Not really an answer to the real issue, but an alternative that somehow worked:

I ended up loading the recovery partition on the new Mac (CMD+R while booting), and choosing to restore from TimeMachine.

It took about 15-20 minutes to completely restore everything, and the new computer has been running fine ever since.

I know this is usually a bad idea, since I'm restoring to a completely different machine, but it seems to have worked with no obvious ill results.

Just an option if you are desperate as I was.

0

This happened to me when migrating to my current Macbook Pro. What worked for me was to migrate everything except Applications, and then reinstall those as needed. Fortunately, since it does still copy over your home directory, all my Application preferences were still there, so it was fairly painless.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .