I used iMovie a lot in the past days (Mac Mini Late 2012 - Mac OS X 10.10) but now if I press the icon in the dock it just does nothing. With spotlight search the same and opening it from the Finder makes no change either. I looked at the Console and the error was the following:

18:51:18 Dock: LSOpenFromURLSpec(file://Applications/iMovie.app/) failed with -10699

In some other forum it said to deinstall and install the Adobe Flash but that did not work. Also I rebooted my Mac which made no change.

Has anyone got an idea how to fix it without reinstalling (if possible)?

  • Just out of curiosity, what do you have against reinstalling? (I assume you mean an OS reinstall.) I get that it takes quite a while, but could you leave it running overnight or something? – user24601 Dec 14 '14 at 3:59
  • No I meant reinstalling iMovie. I thought it would remove my current project too. But I did reinstall it and it worked again :) @user24601 – LinusGeffarth Dec 14 '14 at 4:24
  • Good to hear! If the problem ever occurs again and you feel like being paranoid about data loss, you could just make a copy of your Movies folder, which holds all of iMovie's source files. – user24601 Dec 14 '14 at 4:26
  • @user24601 yeah I copied the project from the iMovieLibrary just in case it would kill my files. But thanks anyway :) – LinusGeffarth Dec 14 '14 at 4:32

Ok so I reinstalled iMovie which made it work again. (I didn't want to do it since I thought it would remove my project I was working on)


i am having the same problem as well. i have now figured out that it is because of a software update/adobe flash player being opened incorrectly. have you ever heard of putlocker or have you watched anything on an illegal website-this tends to open ads which give you cookies which lead to the opening of software that you don't need and especially don't want. if you have ever opened anything, even if you didn't really notice, then this has probably trashed your computer- your mac will slowly start to die and in about two months it will be totally dead, none of the apple stores can fix it-at least not for a good price. the only thing you can do is try to get rid of your computer/laptop and get another one. DO NOT WAIT! go into an apple store right now and ask to trade your laptop/computer in. i hope they let you trade it, they let me and now i am writing this on my apple mac book air! your truthfullly, girl online

  • ahm...is this spam? I don't think that is correct at all. And as I posted below I just reinstalled iMovie and everything worked again. Also, I had that problem about 3 months ago, your description of 2 months is totally mixed up. – LinusGeffarth Mar 24 '15 at 17:51
  • I think this answer is in serious need of a foil hat. – Tetsujin Mar 24 '15 at 18:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .