1

I have several Gmail accounts. One in particular started demanding the password before sending emails. I have two factor authentication with the unrecoverable password so I had to delete the account and create it again.

This has led to Mail.app not synching that account anymore. I have the disconnected thunderbolt symbol over it, and hitting the send/receive button seems to do nothing.

Is there something I can do to force Mail.app to work normally with that account? All others are fine.

  • check your keychain for that account – Ruskes Dec 13 '14 at 21:28
1

Tested on a 10.10.3 Yosemite MBP. I assume that you have created the Gmail account in the first place and that an entry exists in the Accounts tab of Preferences in Mail.app.

If you have enabled two factor authentication in your Google account then you need to create an App Password at https://security.google.com/settings/security/apppasswords?pli=1. This is a critical step.

Take this password you have just generated and go to Mail.app > Preferences > Accounts > your Google IMAP Account > Password field and add that password. Copy/paste works.

If it's a problem just to send mail, from the same place click the Outgoing Mail Server dropdown > Edit SMTP Server List... tab > smtp.gmail.com > Advanced tab > Password field and populate it with the same Google App Password.

Either way, close preferences and say yes when prompted to save changes.

Now, still in Mail.app, click Window > Connection Doctor and investigate the information there. You are looking for two entries, one is Google IMAP and one is SMTP next to the Google account name you are concerned with.

If you have green lights, you are good to go. Red lights indicate a server communication problem.

You can change passwords now that you know where without deleting/creating a new account every time you have an issue.

0

I assume you deleted the gmail account in Mail.app.

Then you recreated it using Mail.app (+) to add new account.

I assume you entered the correct IMAP info:

Incoming mail imap.gmail.com

Outgoing mail smtp.gmail.com

You also did the "Enable this Account" in the Mail Preferences Accounts window.

You also have the Port: 993 and Use SSL.

You do not have anything in the IMAP path prefix window.

Password:

Is stored in your keychain. Find it and check the access control for it.

  • Access control is appleaccount, the same as the accounts that work. – ruipacheco Dec 13 '14 at 23:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .