4

This pattern repeats once every hour?

12/12/2014 04:20:59.000 kernel[0]: Wake reason: RTC (Alarm)
12/12/2014 04:20:59.000 kernel[0]: RTC: SleepService 2014/12/12 04:20:59, sleep 2014/12/12 03:21:01
12/12/2014 04:20:59.000 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000340
12/12/2014 04:20:59.000 kernel[0]: AppleCamIn::wakeEventHandlerThread
12/12/2014 04:20:59.000 kernel[0]: Previous Sleep Cause: 5
12/12/2014 04:20:59.000 kernel[0]: AppleHSSPIController::HandleMessage Device Wake by Host
12/12/2014 04:20:59.000 kernel[0]: AppleThunderboltNHI::prePCIWake - power up complete - took 180846 us
12/12/2014 04:20:59.000 kernel[0]: AppleThunderboltHAL::earlyWake - complete - took 1 milliseconds
12/12/2014 04:20:59.258 hidd[70]: MultitouchHID: device bootloaded
12/12/2014 04:20:59.000 kernel[0]: Thunderbolt Self-Reset Count = 0xedefbe00
12/12/2014 04:20:59.000 kernel[0]: IOThunderboltSwitch<0xffffff8028fed800>(0x0)::listenerCallback - Thunderbolt HPD packet for route = 0x0 port = 11 unplug = 0
12/12/2014 04:20:59.000 kernel[0]: TBT W (2): 0x0100 [x]
12/12/2014 04:20:59.000 kernel[0]: IOThunderboltSwitch<0xffffff8028fed800>(0x0)::listenerCallback - Thunderbolt HPD packet for route = 0x0 port = 12 unplug = 0
12/12/2014 04:20:59.000 kernel[0]: ARPT: 91334.258121: si_survive_perst_war: bar0win before 18003000, bar0win after 18001000
12/12/2014 04:20:59.000 kernel[0]: ARPT: 91334.261266: pcicore_pci_pmeclr PMECSR : 0x4008
12/12/2014 04:20:59.000 kernel[0]: ARPT: 91334.261275: pcicore_pmestatclr PMECSR : 0x4008
12/12/2014 04:20:59.000 kernel[0]: ARPT: 91334.261378: pcicore_pci_pmeclr PMECSR : 0x4008
12/12/2014 04:20:59.000 kernel[0]: en0: BSSID changed to 60:33:4b:e1:53:1c
12/12/2014 04:20:59.000 kernel[0]: ARPT: 91334.507572: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
12/12/2014 04:20:59.000 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000340
12/12/2014 04:20:59.000 kernel[0]: AppleCamIn::wakeEventHandlerThread
12/12/2014 04:20:59.662 airportd[84]: _doAutoJoin: Already associated to “Airport - TC1TB (5 GHz)”. Bailing on auto-join.
12/12/2014 04:21:01.049 ntpd[44]: ntpd: wake time set +0.310571 s
12/12/2014 04:21:01.070 com.apple.time[164]: Interval maximum value is 946100000 seconds (specified value: 9223372036854775807).
12/12/2014 04:21:01.076 com.apple.time[164]: Interval maximum value is 946100000 seconds (specified value: 9223372036854775807).
12/12/2014 04:21:04.000 kernel[0]: AppleCamIn::handleWakeEvent_gated
12/12/2014 04:21:04.000 kernel[0]: AppleCamIn::handleWakeEvent_gated
12/12/2014 04:21:46.223 ntpd[44]: ntpd: wake time set -0.148252 s
12/12/2014 04:21:46.241 com.apple.time[164]: Interval maximum value is 946100000 seconds (specified value: 9223372036854775807).
12/12/2014 04:21:46.247 com.apple.time[164]: Interval maximum value is 946100000 seconds (specified value: 9223372036854775807).
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.078880: AirPort_Brcm43xx::powerChange: System Sleep 
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.078889: wl0: powerChange: *** BONJOUR/MDNS OFFLOADS ARE NOT RUNNING.
12/12/2014 04:21:46.000 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000340
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566519: scanparams:
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566524: flags 0
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566526: active_time 0, passive_time 0
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566528: scan_start_delay 0
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566530: scan_cycle_idle_rest_time 0, scan_cycle_idle_rest_time_multiplier 0
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566533: max_scan_cycles 0, max_rest_time 0
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566535: Scan Channels (0): None
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566537: SSID (0): None
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566539: SSID count = 0
12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566541: wl0: leaveModulePoweredForOffloads: Wi-Fi will stay on.
12/12/2014 04:21:46.000 kernel[0]: AppleThunderboltNHI::prePCIWake - power up complete - took 1337 us
12/12/2014 04:21:46.000 kernel[0]: AppleThunderboltHAL::earlyWake - complete - took 0 milliseconds
12/12/2014 04:21:46.000 kernel[0]: Thunderbolt Self-Reset Count = 0xedefbe00
12/12/2014 04:21:47.000 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000340
12/12/2014 04:21:47.000 kernel[0]: AppleThunderboltNHIType2::waitForOk2Go2Sx - retries = 2
5

I think this may be your Bonjour Sleep Proxy waking up your Mac to see if it's alive. Take two of these and call me in the morning:

http://support.apple.com/en-ca/HT201960

And also check this:

http://ispire.me/fix-yosemite-rtc-alarm-wakeup-issue/

  • Haha, thanks. Ok I think this might be it. Not sure how to verify though. A friend picked up my laptop with wet hands, and I thought possibly got the Thunderbolt port wet, causing this behaviour! – Woodstock Dec 13 '14 at 9:56
  • I suspect that the two are not related. Normally BSP needs to have an apple-aware router for that to be the cause. What router do you use? It is an AirPort of some sort? I should have asked this in the first post... – Maury Markowitz Dec 13 '14 at 14:56
  • Yes I use a time capsule! - does this mean it's likely that this is normal behaviour? – Woodstock Dec 13 '14 at 21:49
  • Yes. And it always freaked me out too, especially on my old Mac Pro which you could hear across the house. :-) Basically if you have any sort of sharing turned on, when your machine goes to sleep it hands off a message to the TC that lets the TC pretend to be your machine. Then when anyone wants to talk to your machine, the TC intercepts the messages, says "wait please", wakes your machine and hands off. To keep it working, the TC periodically wakes up the machine to re-read the list of services. And THAT is the problem - you have no control over this process other than on/off. – Maury Markowitz Dec 14 '14 at 15:25
2

Normally a Mac will wake to do some housekeeping, including checking email. However, its not a 'full wake' in that the screen does not come on, external drives don't mount etc.

My iMac does this every hour, but the screen does not come on.

  • 1
    do you have log entries like mine? – Woodstock Dec 12 '14 at 20:56
2

Maury is probably correct that BSP is waking your Mac while it is sleeping...

This log line indicates that you do appear to be connected to an Apple TimeCapsule Airport wifi network:

12/12/2014 04:20:59.662 airportd[84]: _doAutoJoin: Already associated to “Airport - TC1TB (5 GHz)”. Bailing on auto-join.

This line suggests that your Mac may be waking due to a Bonjour/MDNS over the network:

12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.078889: wl0: powerChange: *** BONJOUR/MDNS OFFLOADS ARE NOT RUNNING.

And this line suggests that your Mac has Wake for Wi-Fi network access enabled in the Energy Saver Panel of System Preferences:

 12/12/2014 04:21:46.000 kernel[0]: ARPT: 91381.566541: wl0: leaveModulePoweredForOffloads: Wi-Fi will stay on.

The line above indicates that it is leaving Wi-Fi enabled while your Mac is sleeping.

The two links Maury provided have information and solutions that work, but they require some interpretation:

  • the Apple Support article explains Wake on Demand and Bonjour Sleep Proxy but doesn't explicitly explain how to disable these features:

    • these should be disabled by unchecking the Wake for Wi-Fi network access and Enable Power Nap while plugged into a power adapter in the Energy Saver System Preferences panel
    • these features can be disabled provided you do not have your Mac providing these services while sleeping:
      • iTunes and iPhoto Sharing, Printer Sharing, Back to My Mac, Local File Sharing, Screen Sharing, other sharing services
    • if you are using these features some can be done with your TimeCapsule instead
  • the 2nd link provides instructions to deactivate these features by disabling multicast for the discoveryd service daemon, which seems like a poorer solution than turning off these settings in the Energy Saver panel

0

My sample size isn't enough for me to be sure but... It seems that for me keeping Microsoft Excel open when the mac goes to sleep, causes these strange wakeups in my case. I had tried all the obvious options. I was looking through the system logs and saw some strange entries for MS. Having quit Excel over night the wakeups have seized so far.

I had previously wiped my disk as last resort before hardware replacement. It looks like it was to blame Excel all along!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .