0

Yesterday everything was fine but today my macbook freeze/stuck during the boot.

I've done this:

  • check + repair permission (nothing changed)
  • check + repair disk (nothing changed)
  • tried safemode (doesn't boot)
  • resetting pram with cmd+opt+p+r (nothing changed)
  • boot in verbose mode, shift+cmd+v and after "waiting for DSMOS" appear disk0s2: I/O error. (now 6 times, but it will continue I think )
  • tried to use fsck in single user mode and it says that the disk is ok
  • tried to reinstall the OS (nothing changed )

enter image description here

Any idea how to solve it?

1

I/O problems are a good indicator that your drive is past its best. Replace the drive or do the following...

Back up everything of value via Target Disk Mode (if possible) then boot your MacBook from a USB or DVD installer. Run Disk Utility, selecting the secure erase/zero fill option and wipe your drive.

This will issue an ATA secure erase command that will fill every allocation block with a zero, automatically mapping out any bad blocks/sectors that will be causing your I/O problem. This is the modern equivalent of the old low-level format, and while there is some debate on the subject I use this method regularly and it works well - assuming the drive isn't riddled with bad blocks.

All FSCK does is check the file structure, it doesn't scan the drive surface to determine if the drive has any damaged sectors. Even the drive's internal SMART diagnostics may indicate all is well when in actual fact the drive is on its way out.

  • Thanks for the answer. I left "working" the boot for more than an hour in verbose mode and when I went back I found my mac on. Any idea how is this possible? <br> I'm scared to turn it off :) – dborghez Dec 12 '14 at 15:07
  • It will have booted eventually through persistent attempts at reading the potentially damaged blocks on the disk, either managing a successful read or simply timing out and moving on. Either way, now's a good time to backup your files! What OS are you running at the moment? Making a USB installer is the quickest way of restoring/wiping a system but the method of creating a USB installer is different for 10.9/10.10 than the older installer type found on 10.6/10.7/10.8 – – ScunnerDarkly Dec 12 '14 at 16:04
  • I launched the utility disk while the mac is on and than I've rebootted it, it looks it works. Hope everything it's solved :) Btw, I really should do a backup of my files, I should do a time machine! – dborghez Dec 12 '14 at 17:58
  • UPDATE #2: i tried to reboot it again and everything works fine so I did it again in verbose mode to check if the error appear again but it didn't appear :) I think that was an error of a improper shutdown (like remove the battery) so maybe it's solved. What do you think? – dborghez Dec 12 '14 at 18:04
  • 1
    Definitely back your stuff up. As I said before, I/O errors are not a good sign and you should think about drive replacement. HDDs are so cheap for large capacities these days, and SSDs, while comparatively expensive, offer so much of a performance boost they really are worth the extra. I've been hammering an OWC 480GB SSD for the last two years without a single issue. Back to the main point though, in addition to thinking about replacing your drive you should also get hold of a copy of DiskWarrior. This will give you a much more thorough disk repair, finding catalog faults Disk Utility misses – ScunnerDarkly Dec 13 '14 at 11:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .