2

I'm experiencing an issue where the Firewall in OS X Yosemite is repeatedly preventing me from launching ARD Admin.

Symptoms: Launch ARD and no window appears. I am forced to force-quit the application.

Troubleshooting: I open up System Preferences > Security > Firewall and ensured that both ARDAgent and ScreenSharing are in the allowed list. They are. Added Remote Desktop.app for good measure, though this shouldn't be necessary.

Upon reboot and login of the computer, I am prompted to allow ARDAgent.app through the firewall. I accept. ARD Admin then launches correctly for the duration of my session. In this environment I am forced to log out at the end of the day (there's a 60 minute inactivity timer enforced to this effect as well). Upon my next login I cannot launch ARD Admin again (its still listed in the firewall as allowed) and I am forced to repeat this troubleshooting process every day.

Inconsistencies:

  1. Sometimes the reboot and login triggers the prompt to allow ARDAgent. Sometimes it does not. I cannot consistently reproduce the behavior that allows me to use ARD Admin. I just keep rebooting until it eventually prompts me and lets me in.
  2. Today I got the prompt to allow ARDAgent and I STILL couldn't launch ARD Admin after accepting the prompt.

Environment:
iMac15,1 (Retina 5K Late 2014) running OS X Yosemite 10.10.1
OS X Firewall Enabled
ARDAgent 3.8
Remote Desktop (ARD Admin) 3.7.2

  • Thank you for writing a good question with lots of detail. – Flying Trashcan Dec 12 '14 at 14:30
  • You have turned on remote management in the Sharing control panel, right? – Steve Chambers Dec 12 '14 at 23:59
  • Remote Management is enabled in the Sharing pane. – Sean Hansell Dec 15 '14 at 13:32
1

Quit ARD if running, and go to [your home]/Library/Containers. Move the folder com.apple.RemoteDesktop to your desktop and see if ARD Admin still has startup issues. If it starts working properly you can trash the com.apple.RemoteDesktop folder. Note this will reset ARD and lose any custom UNIX commands you may have set up, back those commands up first before trashing the folder permanently.

1

I had a similar issue as well on Mavericks. It is very very strange that it is so hard to make an app exception.

On Mavericks you have two firewalls on the system. We used a 3rd party tool called icefloor to configure the pf firewall and avoid the application based firewall. Be sure to check icefloor's compatibility with Yosemite.

http://www.techrepublic.com/article/configure-apples-built-in-network-firewall-with-icefloor/

http://www.hanynet.com/icefloor/

"IceFloor runs on OS X 10.10 Yosemite with limited functionalities. Bandwidth management is not supported. Please do not apply any bandwidth rule on OS X 10.10 Yosemite"

For me it was not a launch issue but a connection to clients issue

You must log in to answer this question.

protected by Community Apr 30 '15 at 20:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .