0

I keep getting this message:

mail can’t open because its index is read-only.

I’ve reinstalled the os, i’ve “fixed permissions”

Nada

  • no need to SHOUT ! – Ruskes Dec 12 '14 at 3:43
1

I've seen this once before and was able to fix it by deleting the index rather than changing the perms. I didn't (and still don't) really understand what I did to get into the situation, nor what it did by deleting the files, but I got away with it.

Disclaimer: I use mac mail as an IMAP client so blowing away files willy-nilly isn't overly dangerous for me. If you delete each message from the mail server as you download it and the only copy of your mail is on your client, your mileage may vary, at the very least, take a copy of anything important.

On Mavericks, the indices are located in your home directory under Library/Mail/V2/MailData/Envelope Index

1

Try forcing an index rebuild…

  1. Quit Mail if it's running.

  2. Go to ~/Library/Mail/V2/MailData

  3. Delete all files that begin "Envelope Index" (drag to desktop for safety)
  4. Launch Mail. It will start to rebuild. This may take a long time.
  5. Once you are satisfied that it worked, you can delete the desktop copies of the indexes.

This would normally be the first step, but I think in your case it may need to be done second.

If it is still not 100% right, then manually rebuild each mailbox, Select a mailbox, then from the Mailbox menu, select Rebuild. This will also take a long time & needs to be done for each mailbox.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .