Few days back I installed Team Viewer on my MacBook Pro running OS X 10.9.4 Mavericks. It worked fine at the first. Now the app is stuck on the dock saying "Application not responding" and it's running indefinitely.

What I've tried to stop the app from running

  1. Force Quit from Dock
  2. Killing from Activity Monitor
  3. Tried to restart the mac and the app launched automatically even though it's not set to launch during startup under system preferences.

There are two processes using the CPU which when I try to force quit gets automatically relaunched.

enter image description here

How do i stop the app or how do I stop these processes from running ever again?

  • I have version 8.0.16901 and it responds to Force Quit using alt+cmd+Esc!
    – Ruskes
    Dec 12, 2014 at 2:57
  • I also do NOT have the TeamViewer_Desktop process running. Are you connected to someone ?
    – Ruskes
    Dec 12, 2014 at 3:03
  • @Buscar웃 - Nope, I'm not connected to anyone. The app won't load for force quit using alt+cmd+Esc!
    – Jash Jacob
    Dec 12, 2014 at 3:06
  • Can you run the Uninstall TeamViewer ?
    – Ruskes
    Dec 12, 2014 at 3:17
  • @Buscar웃 I wasn't able to uninstall because the app was still running.
    – Jash Jacob
    Dec 12, 2014 at 3:24

3 Answers 3


It is probably a launchctl process that is restarting.

To see all loaded launch agents, in Terminal:

launchctl list

To remove one:

sudo launchctl remove label_of_program_to_remove

where, label_of_program_to_remove is found in the preceding list. Note that you have to run the sudo command from an administrator account; or, su to an administrator account first.

  • I found two labels - com.teamviewer.desktop and com.teamviewer.teamviewer, but when I try to remove it sh-3.2# launchctl remove com.teamviewer.teamviewer it says this launchctl remove error: No such process
    – Jash Jacob
    Dec 12, 2014 at 3:11
  • I was able to remove it from the list without using sudo.
    – Jash Jacob
    Dec 12, 2014 at 3:24
  • 2
    Great! Now that that is working, the second (and more permanent) step is to move the com.teamviewer files from either /Library/LaunchAgents/ or your ~/Library/LaunchAgents/ folder. Instead of removing them outright, you should move them someplace else in case you want to try again.
    – Kent
    Dec 12, 2014 at 4:17
  • Ok, what the heck. I have used launchctl to stop, unload, and remove all the teamviewer processes and it no longer shows up in launctl list and I moved all the plist files away, but I still get error messages in system.log saying it's trying to run something every 10 seconds and is failing!
    – Michael
    Mar 4, 2016 at 19:06
  • Can you open a new question, and copy the error message as well as the output of "launchctl list" (remove anything that might compromise your privacy, etc)
    – Kent
    Mar 5, 2016 at 2:32

Go to the Teamviewer preferences. Under the general tab unclick "Start TeamViewer with system". Apply and afterwards you should be able to close the program.

  • It doesn't work if the Teamviewer is forever not responding
    – Jash Jacob
    May 6, 2015 at 15:26
  • I installed TeamViewer Host - where is the preferences?
    – Spike0xff
    Sep 15, 2016 at 2:16

I think the best option is to reinstall TeamViewer. In a a situation where you're unable to uninstall because TeamViwer is currently open (which you can't close) follow the steps below:

  1. On TeamViewer Go to Preferences.
  2. Select Advanced from the tabs.
  3. Scroll down to the bottom and select uninstall.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .