I have an iPhone 5 running iOS 8.1.1. My Calendar app is showing me a ridiculous number of birthday calendars ("Friends' Birthdays" under Gmail, "Birthdays" under Facebook, and 8 separate calendars named "Birthdays" under "Other"). This is what the list of calendars looks like:

Birthday calendar madness

I have no idea how they got there. I am syncing the Calendar app with Google, Facebook, and Meetup, but I can't imagine how that would produce such a ridiculous number.

What can I do about these? I would like to delete or merge some of them but the app is not giving me the option. Is it possible to delete most of them without losing anyone's birthday?

If I look at the Calendar app on my Mac (which is running Yosemite), I don't see all of these calendars. I only see one under Google that says "Birthdays", another under Google that says "Friends' Birthdays", and one under Other that says "Birthdays".

EDIT: I did some looking around and it seems like the "Birthdays" calendar under Gmail has my contacts' birthdays and the "Friends' Birthdays" calendar has my Facebook Friends' birthdays. But all of those "Other" birthday calendars don't seem to have a single birthday in them. I think I can delete them safely without losing anything. I just need to know how, but I don't see any sort of option to delete them.

I logged into iCloud using the iCloud website. I clicked on the calendar icon and all I saw was two empty calendars called "Home" and "Work". I did not see all the empty birthday calendars. I didn't see anything useful or meaningful, but I wouldn't expect to because I am syncing all of my calendar events with Google, not iCloud.

I noticed that the "Other" birthday calendar I saw on my Mac didn't have any birthdays in it, so I deleted it. But I refreshed the calendars on my iPhone as described here and it didn't seem to do anything. I still see 8 "Other" birthday calendars.

  • 1
    What happens when you manually tap on the item? In my case I can simply tap on a "Birthdays" to disable. – J A Dec 14 '14 at 17:16
  • I can disable the calendars by tapping on them. But I can't actually delete them. – Elias Zamaria Dec 14 '14 at 17:39
  • Do you own another apple device? If you do, sign in with your apple id and check the calendar app. If it shows the birthday cal's we know it has something to do with your iCloud settings. if they don't show up I would reset my iPhone. – dennismuijs Dec 18 '14 at 10:42
  • I own a recent MacBook Pro, with Yosemite, that I regularly use. I looked at the Calendar app, noticed one empty "Other" birthday calendar and deleted it. I refreshed the calendars on my iPhone. That didn't seem to do anything. I have a 5-year-old MacBook Pro, which I upgraded to Yosemite, that I rarely touch any more. I looked at the Calendar app on that, explicitly refreshed it, and noticed an empty "Other" birthday calendar. I don't know if it was the same one or a different one but I deleted it. I refreshed my iPhone again and it didn't seem to do anything. – Elias Zamaria Dec 18 '14 at 16:59

As Insomniac Software mentioned, the Birthday calendars come from the Contacts app.

In the Contacts app, it (confusingly) launches at a page that shows an aggregated view of contacts from different sources. Tapping the "Groups" button at the top left of the screen takes you to the list of sources.

You mentioned that on your Groups screen, you have two sources of contacts:

  • Facebook. Birthdays in this group show up in the Calendars app in the "Facebook" section, not in Other, so that's not the cause of the issue
  • On My iPhone. Birthdays in "Other" come from here.

The problem is that, from what you've said, it sounds like your contacts are stored on your iPhone, not in iCloud - otherwise they would show up in an "ICLOUD" group, not an "On My iPhone" group.

To solve your calendar issue and to prevent potentially losing your contacts:

  • Select a place to store your contacts. I'll give an example for iCloud because I suspect your contacts were there and got dumped on your phone while changing settings. If you think you have them stored in gmail, post a comment and I'll update my answer.
  • Move the contacts to your selected location. To merge them to iCloud: go to Settings > Mail, Contacts, Calendars > iCloud, turn on "Contacts". It should tell you "Your contacts will be merged with iCloud". Tap ok to allow it.
  • Go back to the Contacts app, tap "Groups". You should see an "ICLOUD" group. It may take several minutes to sync - go get coffee and come back if you don't see it. You should not see an "On My iPhone" group.

Now, you need to make sure your contacts are there. In the Contacts app on the Groups page, to see what's in a particular source, tap the boxes under each group heading until the checkbox is only on the one you want to see. So, to see what's in your iCloud contacts, there should only be a checkmark on the box under the "ICLOUD" group heading. Then, tap "Done" in the upper right corner to see the contacts - it'll only show the contacts in the selected source (i.e. iCloud).

Then, open your Calendar app, wait a minute for it to sync, and tap Calendars. If your 8 Birthday calendars are still there:

  1. Close the app, wait 5 minutes, check again.
  2. If they're still there, continue. If they're gone, you're done!

If your Birthday calendars are still there:

  • Go to Settings > Mail, Contacts, Calendars > iCloud, turn off Contacts. Tap "Delete contacts from my iPhone" (very important).
  • Wait a minute for it to sync, then go check your Calendar app. The Birthday calendars should be gone. If they're not, give it a couple more minutes. If they're still not, turn your contacts back on anyway (next step) and comment.
  • Go to Settings > Mail, Contacts, Calendars > iCloud, turn on Contacts to get your contacts back.
  • Wait a minute, then go check your Calendar app. The Birthday calendars should still be gone.
  • I neglected to mention that I don't usually see the "On My iPhone" group in my contacts. It only seems to show up if I disable my contacts for both Gmail and iCloud. When I tried that, the "On My iPhone" group was empty, as I would expect it to be, since I chose to delete the Gmail and iCloud contacts when I disabled them. I am planning to put all of my contacts in either Gmail or iCloud some day, but I haven't gotten around to it yet. When I turned on my contacts for iCloud, the slider thing just turned on without telling me that anything would be merged. – Elias Zamaria Dec 20 '14 at 0:38
  • Disabling the Facebook and Gmail groups in the Contacts app didn't prevent the empty birthday calendars from showing, even after closing the app and waiting 5 minutes like you said, and even after pulling to refresh on the list of calendars. Even disabling all of the groups didn't prevent the empty birthday calendars. – Elias Zamaria Dec 20 '14 at 0:54
  • I don't want to move any contacts from one account to another, because I don't know what the effects of that would be, and if that would cause even more weird annoying problems like duplicate contacts or contacts not showing up in Gmail. I'm experiencing enough glitches. But I'm willing to try it if I get really desperate. – Elias Zamaria Dec 20 '14 at 0:57
  • I tried turning off the contacts in Settings for both my iCloud and Gmail accounts, killing the calendar app, waiting 5 minutes, restarting it, viewing the list of calendars, and pulling to refresh it, and the "Other" birthday calendars are still there. – Elias Zamaria Dec 20 '14 at 1:03

I managed to remove all birthdays event on my iPhone calendar.

I went to Settings > Mail, Contacts, Calendars,

In iCloud and all my email account, I turned off calendar.

Then I switch my phone off and on it again.

All birthday events in the calendar are now gone.

  • 1
    I am not trying to remove any events. I am trying to remove the 8 birthday calendars that don't have any events. I tried what you suggested and it didn't fix anything. – Elias Zamaria Jan 21 '15 at 19:57

Just in case anyone keeps pulling this up on google, take a look at https://discussions.apple.com/thread/7671336?start=0&tstart=0

It seems since iOS 10 this issue (or at least a very similar one) has reemerged, duplicating 'Facebook' and 'Other' birthday calendars hundreds of time.

It's a little strange, but I guess those birthday calendars are related to your iCloud account. Got to Settings > Mail, Contacts, Calendars > iCloud and turn off and on Calendars.

Hope it helps.

  • I looked at "Calendars" under "iCloud" and I couldn't turn it off because it was already off. I turned it on and looked at my calendars and nothing seemed to change. Then I turned it back off. The Settings app asked me if I want to keep or delete my previously synced iCloud calendars. I chose delete and still nothing happened. – Elias Zamaria Dec 14 '14 at 19:16
  • Just had an idea. Go to Privacy in Settings app, select Calendars and see if any app has requested access to your calendar. Maybe turn them off one by one see if it solves the problem. – Behdad Dec 14 '14 at 19:42
  • I tried what you said. I turned all of the apps off and that didn't solve the problem. – Elias Zamaria Dec 14 '14 at 23:12
  • Well, I must admit this is getting strange :D. I don't know, maybe signing out of iCloud? It's a long shot anyway. – Behdad Dec 15 '14 at 10:45
  • I signed out of iCloud and that didn't remove the empty calendars. I signed back in and everything seems just like it was before. – Elias Zamaria Dec 15 '14 at 19:11

This may be due to Google Calendar. The only reliable way I have found to control what calendars get sync'd to iDevices, is a fairly hidden control panel on Google Calendar:

https://www.google.com/calendar/syncselect

This panel allows you to select which calendars will sync to your iDevice and iCal. Simply uncheck those you don't want in iCal or iPhone, and they will disappear from those devices, but remain in your Google Calendar list.

If you want to know more about these Calendars, you should visit the Google Calendar site. Then select 'Settings' from the Gear icon on the right, choose the "Calendars" tab, and then view the calendars listed. For example, if you have Google+, Google 'helpfully' creates a Birthdays calendar from your Circles. Some calendars you can delete by hitting the 'unsubscribe' link, but others, including the Google+ Birthdays calendar, you can not delete (thanks Google). However, the sync link above will prevent them from showing on your Apple Device.

  • I looked at that hidden control panel. I see Google's built-in birthday calendar and the "Friends' Birthdays" calendar from Facebook, both of which have actual birthdays that I don't want to lose. I don't see the many empty birthday calendars that I'm trying to get rid of. – Elias Zamaria Dec 15 '14 at 19:22

The Other Birthday entries are collected from the Contacts, not from a Calendar. In the Settings > Mail, Contacts, Calendars screen, how many accounts do you have with Contacts enabled?

It will create a Birthday calendar entry under Other for each account, even if there are no contacts with birthdays entered.

  • I have 2 accounts: an iCloud one and a Gmail one. I tried disabling the contacts for both accounts, switching to my Calendar app and refreshing it. I still see 8 empty "Other" birthday calendars. – Elias Zamaria Dec 18 '14 at 17:06
  • When you disabled the contacts, did you choose to delete from your phone? If not, they would change to phone-only contact entries and would remain in the birthday calendars. Try disabling the contacts for all accounts, choosing to delete from your phone (they will remain safe in the cloud) but switch to the Contacts app instead. If you have any contacts listed, those are local to the phone only (and should be moved out). If you have a Groups link in the top left corner, click on it and see what local groups are being used. Pull down on the screen to refresh and it will rebuild the b-day list – Insomniac Software Dec 18 '14 at 19:14
  • Yes, I did. I even verified that the contacts were deleted by starting the Contacts app and noticing that the list was empty. I thought that since that didn't seem to fix the problem, I turned the contacts back on. I can't remember if there was a Groups link but I can try doing the same thing again. – Elias Zamaria Dec 18 '14 at 19:53
  • I just disabled and deleted the contacts from Gmail and iCloud. I then started the Contacts app. I still see some of my contacts (even though I swear I didn't see any the last time I tried that). I clicked the Groups link and I saw 2 groups: one under "Facebook" called "All Facebook" and another under "on my iPhone" called "All on My iPhone". I pulled down to refresh and nothing seemed to change. I looked in the Calendar app and I still have 8 empty birthday calendars. – Elias Zamaria Dec 18 '14 at 19:58
  • 1
    Then you don't need OrbiTools. It is one of the few apps I've found that lets you move contacts between lists. Since the 'on my iphone' list is empty, there isn't anything to move. The wipe & restore step is a pain but is the last option, and it is what Apple would do if you took it to the Genius Bar. Follow the procedure as if you were replacing the phone with a new one. Back it up on your computer with iTunes then Settings>General>Reset>Erase All Content and Settings. Start again with Restore From Backup. If the b-day lists return, I'm at a loss. If not, turn on one account until it happens – Insomniac Software Dec 20 '14 at 17:47

Try going to Settings > Mail, Contacts, Calendars

Here, select each email account you have and toggle the switches for things like notes, calendars, contacts .etc

if you turn off calendars, the birthdays should disappear.

  • I have already tried disabling the calendars and contacts for each account, as I have described in my contacts to other answers, and that didn't remove the empty calendars. I just tried disabling the calendars, contacts, and notes, all at the same time (even though I can't imagine how disabling notes can fix this problem) and that also didn't remove the empty calendars. – Elias Zamaria Jan 13 '15 at 19:05
  • @EliasZamaria try backing up and resetting your phone. then set it up as a new iPhone and see if the problem persists. – DeveloperACE Jan 18 '15 at 1:44
  • I backed up and restored my phone as described in one of the comments for this answer and it didn't fix the problem. – Elias Zamaria Jan 18 '15 at 4:14
  • 1
    Well this is puzzling... Just a last idea to throw out there, you could email Tim Cook... – DeveloperACE Jan 18 '15 at 18:10
up vote 0 down vote accepted

I just looked at my Calendar app and the empty birthday calendars are not there. I recently updated to iOS 8.3, and I can't imagine what else could have fixed it, so I'm guessing it was that.

Since this issue came up again for me (and others) in iOS 10, and this post ranks so high in google, just wanted to mention that updated to 10.3 fixed it for me.

protected by Community Feb 20 '15 at 12:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.