2

I have purchased, downloaded and installed Apple Remote Desktop 3.7.2 from the Mac App Store (onto a computer that's running OS X Yosemite 10.10.1).

When I first open the app, I am prompted to agree to the licence. Once I indicate my acceptance to its terms, the licence dialog disappears and the app stops responding (nothing further is displayed and the cursor turns to a spinning wheel if I try to access the unresponsive menubar; I am left with no choice but to force-quit the application).

Executing the app binary directly reveals the following messages on stderr:

2014-12-11 20:26:54.654 Remote Desktop[44453:2412661] *** -[__NSSetM addObject:]: object cannot be nil
2014-12-11 20:26:54.655 Remote Desktop[44453:2412661] (
    0   CoreFoundation                      0x00007fff85b6264c __exceptionPreprocess + 172
    1   libobjc.A.dylib                     0x00007fff8f1a16de objc_exception_throw + 43
    2   CoreFoundation                      0x00007fff85a6fcb9 -[__NSSetM addObject:] + 329
    3   Remote Desktop                      0x0000000101a92fcb Remote Desktop + 1974219
    4   CoreFoundation                      0x00007fff85b1ecbc __CFNOTIFICATIONCENTER_IS_CALLING_OUT_TO_AN_OBSERVER__ + 12
    5   CoreFoundation                      0x00007fff85a101b4 _CFXNotificationPost + 3140
    6   Foundation                          0x00007fff932abea1 -[NSNotificationCenter postNotificationName:object:userInfo:] + 66
    7   AppKit                              0x00007fff92561187 -[NSApplication finishLaunching] + 440
    8   AppKit                              0x00007fff92560c51 -[NSApplication run] + 128
    9   AppKit                              0x00007fff9254c2d4 NSApplicationMain + 1832
    10  Remote Desktop                      0x000000010191af23 Remote Desktop + 433955
    11  Remote Desktop                      0x00000001018b3634 Remote Desktop + 9780
    12  ???                                 0x0000000000000001 0x0 + 1
)
2014-12-11 20:26:54.768 Remote Desktop[44453:2412661] *** -[NSLock lock]: deadlock (<NSLock: 0x7fa01b48a830> '(null)')
2014-12-11 20:26:54.768 Remote Desktop[44453:2412661] *** Break on _NSLockError() to debug.

I have tried uninstalling and reinstalling ARD, to no avail—although it may be significant to note that, besides /Applications/Remote Desktop.app and ~/Library/Containers/com.apple.RemoteDesktop, none of the expected file paths exist.

What's going on? How can I get ARD to work?

  • There's an Apple KB article on uninstalling ARD: support.apple.com/en-us/HT201766 – pknz Dec 11 '14 at 20:41
  • @pknz: I'm already aware of that article (indeed, I linked to it from my question!). Are you suggesting it should solve my problem? Have I overlooked something? Please elaborate. – eggyal Dec 11 '14 at 20:45
  • Sorry! Skimmed over that. Have you tried opening from another user account? – pknz Dec 11 '14 at 21:07
  • @pknz: Yes—no difference. – eggyal Dec 11 '14 at 23:40
3

One issue I have noted that causes a hang on launch of the Apple Remote Desktop admin app is when the ARDAgent process can't be reached.

Killing the ARDAgent process fixes the hang-on-launch.

Here is one way to kill ARDAgent:

  1. Open /Applications/Utilities/Activity Monitor.app
  2. Select the "CPU" tab.
  3. In the search box, type "ARDAgent". You should see two ARDAgent processes, one running as user 'nobody', one running as you.
  4. Select the ARDAgent process belonging to user 'nobody', and choose the "X" symbol on the toolbar to kill the process. In the dialog that pops up, choose "Force Quit".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .