2

My mid2014 retina pro keeps crashing, can't boot into safe mode and can't choose utilities when booting into recovery mode because no mouse commands are accepted. (not sure what key combo would choose a utility such as disk recovery) it resolves itself over time--not sure how.

I Kept the log from last night's crash == 92 pages so i tried to post what might be relevant but i really have no idea. Any help is greatly appreciated, thanks in advance

12/10/14 6:24:28.000 PM kernel[0] BUG in process suhelperd[305]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external)   
12/10/14 6:24:24.836 PM com.apple.audio.DriverHelper[202]   The plug-in named AirPlay.driver requires extending the sandbox for the IOKit user-client class IGAccelVideoContextMain.<<<<Note:  there are 6 of these with different devices
12/10/14 6:24:27.000 PM kernel[0]   Sandbox: appleeventsd(26) deny file-read-metadata /Library
12/10/14 6:24:27.000 PM kernel[0]   Sandbox: appleeventsd(26) deny mach-lookup com.apple.ocspd
12/10/14 6:24:28.000 PM kernel[0]   USBF:    9.686    The IOUSBFamily was not able to enumerate a device.
12/10/14 6:24:28.739 PM com.apple.xpc.launchd[1]    (com.apple.imtransferservices.IMTransferAgent) The _DirtyJetsamPriority key is not available on this platform.
12/10/14 6:24:28.739 PM com.apple.xpc.launchd[1]    (com.apple.imtransferservices.IMTransferAgent) The _DirtyJetsamMemoryLimit key is not available on this platform.
12/10/14 6:24:28.740 PM com.apple.xpc.launchd[1]    (com.apple.imfoundation.IMRemoteURLConnectionAgent) The _DirtyJetsamMemoryLimit key is not available on this platform.
12/10/14 6:24:28.763 PM com.apple.xpc.launchd[1]    (com.apple.imfoundation.IMRemoteURLConnectionAgent) The _DirtyJetsamMemoryLimit key is not available on this platform.
12/10/14 6:24:28.847 PM logind[70]  -[SessionManager getClient:withRole:inAuditSession:]:241: ERROR: No session dictionary for audit session 100014
12/10/14 6:24:28.847 PM logind[70]  _SMGetSessionAgent:73: ERROR: __SMGetClientForAuditSessionAgent failed 2
12/10/14 6:24:28.000 PM kernel[0]   BUG in process suhelperd[305]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external)
12/10/14 6:24:29.289 PM com.apple.xpc.launchd[1]    (com.google.keystone.daemon[317]) Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.google.Keystone.Daemon.Administration
12/10/14 6:24:29.289 PM com.apple.xpc.launchd[1]    (com.google.keystone.daemon[317]) Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.google.Keystone.Daemon.UpdateEngine
12/10/14 6:24:29.296 PM GoogleSoftwareUpdateDaemon[317] -[KeystoneDaemon logServiceState] GoogleSoftwareUpdate daemon (1.2.0.7709) vending:
    com.google.Keystone.Daemon.UpdateEngine: 2 connection(s)
    com.google.Keystone.Daemon.Administration: 0 connection(s)
12/10/14 6:24:29.301 PM mds[34] (Server.Warning:445) No stores registered for metascope "kMDQueryScopeComputer"
  • 1
    I found a discussion page that talks about your issue, check it out here. – Vladimir Dec 11 '14 at 18:06
  • That thread suggests that Software update is the culprit. bThe suhelperd is related to the App Store and Software Update. When I open the appStore and check update I get hundreds of kernel[0]: BUG in process suhelperd[289]: over-released legacy external boost assertions (1 total, 1 external, 0 legacy-external). I am Not getting the behaviour you are getting But I do think it is in the right direction for those that are. – markhunte Dec 16 '14 at 15:39
1

This is a Diagnostic not a repair

Following might show what is making it crush.

Copy/Paste the following in to your Terminal (located in the utility folder).

syslog -k Sender kernel -k Message CSeq 'n Cause: -' | tail | awk '/:/{$4=""; print}' | pbcopy

The output will be copied to your clip board.

  • This sounds promising, thank you for your response. When pasting into terminal and then keying Command+V to text editor, i didn't get any output however? – Winston Smith Dec 11 '14 at 20:32
  • If you do not get output then there was nothing to report. – Ruskes Dec 11 '14 at 20:36
0

I'm not sure exactly what's wrong, but try starting your computer in Internet Recovery Mode. If you still can't use your mouse after it fully boots into this mode, then there's likely a hardware issue.

Some computers don't natively support Internet Recovery, so be sure to check out this Apple support article.

But before you try any of the above serious fixes, try reseting the PRAM and SMC on your computer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .