I recently tried to update my iMac OS to Yosemite as most people had already done it a while ago. it downloaded the package when rebooted to install it. It was stuck with error message.

It looks as if there was an issue with hard drive preventing installation. I was also unfortunate to revert the installation, hence end up loosing all my files as I decided to erase the disk and create new partition. Even after formatting the disk and using 'Reinstall OS X' from recovery mode; I am unable to complete.

The screen doesn't seem to do anything stuck at 'Downloading additional components, it will automatically restart' I tried leaving it for few hours but no result.

Would someone please share your experience?

  • 1
    I hope your machine is in warranty, and if so, go to the nearest shop that has applecare support... I doubt anyone here will be able to help you and your question is very much out of scope for what is usually handled in serverfault.
    – Reaces
    Commented Dec 11, 2014 at 12:46
  • 1
    Can you specify the age and hardware of your iMac?
    – user24601
    Commented Dec 11, 2014 at 16:28
  • 1
    Your question can not be answered! it is lacking information: What iMac, what was the previous OS X, what Error did Yosemite show...and so on. If you want help please provide relevant information, since we are unable to guess it.
    – Ruskes
    Commented Dec 11, 2014 at 17:48
  • I have read reports from people that Yosemite update might get stuck (mine was rather smooth), and in that case (stuck for a few hours) just force a reboot and the installation should finish just fine. However, it's a different story if you have a hardware issue. Do as Buscar웃 suggested: do an Apple Hardware test first. Also, my best advice is to go to your local Apple Store (schedule a Genius bar appointment before you go). You don't need a warranty to get help about software.
    – 4ae1e1
    Commented Dec 11, 2014 at 17:50
  • @Buscar웃 For this kind of problems, I'd say it's hard to troubleshoot remotely even if he/she posted relevant information.
    – 4ae1e1
    Commented Dec 11, 2014 at 17:51

5 Answers 5


Try using Internet Recovery Mode instead of the regular Recovery Mode, and make sure that you formatted the right hard drive (in other words if you have an external hard drive plugged in, make sure that you formatted your actual hard drive, not your external one).

Here is some more info about different recovery modes from Apple's support site.


Do not worry about this issue, seems your drive + recovery are corrupt.
Here's a list of stuffs you'll need to fix this problem.

  1. Find a mac nearby (ask a friend or go to apple store)
  2. Download a fresh copy of Yosemite (Apple store people can give you)
  3. Download Lion Disk maker - To make bootable USB of Yosemite - Link : http://liondiskmaker.com
  4. Create a bootable USB Yosemite Installation.
  5. Boot to installation and create NEW PARTITION ( Delete previous partition* Note I'm talking about partition and not logic drives)
  6. Creating new partition will delete your previous mac recovery, but don't worry about it.
    1. Try installing Yosemite, I'm sure this time you won't be prompted by that error.

If this worked, come back to this post again and I'll let you know how to bring or create a new recovery.


If you need to recover your old data, you can do so using PhotoRec. It's a free program that only needs the Terminal to run (in other words, you don't need to restore you full operating system to be able to use it).

If you are able to boot into the Internet Recovery Mode as I mentioned in my previous reply (or even the regular Recovery Mode for that matter), then you should be able to recover your data using PhotoRec.

All you need to do is download PhotoRec onto a flash drive, and once you're in your preferred recovery mode, go to Utilities > Terminal. In the Terminal, you can navigate to your flash drive by typing:

cd /Volumes/NameOfYourFlashDrive

Now, you can just run PhotoRec just as you would normally run any executable from the Terminal.


Thank you all for the response.

I end up calling apple support and they confirmed many people were having same issues with yosemite installation. I had to perform internet recovery to go back to previous version. I have been asked to use this version until apple releases newer OS.


I thought I had this issue. It was just stuck on the "Downloading Additional Components" Screen and the progress bar wasn't moving. Then after maybe 10 or 15 minutes, it started moving along. After a blank screen now at the "Installing on 'Untitled'" screen.

  • 1
    Hi there, Shahryar. What you've posted isn't really an Answer at all. If you end up finding a solution to the problem, please post that as an Answer instead.
    – samh
    Commented Apr 18, 2015 at 19:31
  • Huh? That is an answer. I went through the same thing where I thought the installation crashed but this is just how Yosemite installs.
    – Shahryar
    Commented Apr 20, 2015 at 2:29

You must log in to answer this question.