I wanted to see if my technical hiccup was experienced by others, as well as any obvious fix I am missing.

Perhaps 5-10 times per day, my external, bluetooth, apple magic trackpad will interpret a regular click as a two-finger click (ie a right-click.) I believe it is only when I click via the full "press down" method, it does not happen during a mere light-touch-to-click.

So you are using your trackpad, and you go to it to drag something, for instance, but you then find the darn contextual menu popping up on the thing instead! Agh!

I am guessing I may take it in for a regular exchange (ugh, it was bought on USA apple store online and I am in thailand now) ... but thought I would see how wide-spread or solvable it is.

  • I have taken it to a dealer... after some days, they were apparently not able to replicate the problem. wonder if it is a hiccup with my laptop, my bluetooth universe, or something. we will see. Jul 14, 2011 at 6:52
  • Is the trackpad wet? I've had problems when there was some liquid on the trackpad and it interpreted my one-finger click as a two-finger click.
    – user6124
    Jul 24, 2011 at 4:27
  • nope, not wet. going to OS X Lion didn't help this. yech, still happening. Annoying that I can't simply get it exchanged... just because the problem is very intermittent therefore can't replicate it for the technician. Sep 26, 2011 at 8:45
  • FINAL STORY ON WHAT HAPPENED: As I wrote above, the apple dealer in thailand didn't want to simply replace my trackpad. When I flew to the USA I took it with me and the apple store there immediately just said "let's just trade it in for a new one." (it was still under warrantee.) Result: problem totally disappeared. So it seems it was simply in the hardware. after all that... thanks much. May 21, 2012 at 8:21

7 Answers 7


Do you have checked this in the SystemPreferences -> Trackpad? enter image description here

That's mean, than when you do a full-click on the right(left) bottom corner thats mean right-click. For the disable, simple uncheck.

  • Your point (and screenshot) is excellent ... but in fact I have that checkbox off in my preferences! and it's not lower-right clicking. however, thanks, that was a good idea. Jun 17, 2011 at 1:51

To resurrect this thread - this was driving me crazy. I thought my MacBook trackpad was failing but I recently went back to using a Magic Trackpad and found the same problem there. What happens is I mostly single click with my thumb but if any of my other fingers touched the trackpad it would fire off a right click.

I was hoping there was a solution where you could specify that the two contact points would have to be close to each other. I couldn't find anything like that.

But I did find MagicPrefs, which lets you customize gestures, taps, and clicks. What worked for me was to set the two-finger click to fire a right-click, and to set the applicable zone to the top 3/4 of the trackpad. This way thumb clicks, which are always at the bottom of the trackpad for me, didn't count as a double click and then fallover to a single click.


I don't want to give up right clicking. But I have had the same problem. However I think it might be caused either by hitting too close to right click corner or one of my other fingers either accidentally touching the trackpad or perhaps being detectably close. Try clearly pointing with one finger and the others withdrawn. When doing this you seem to get a "regular click". Working for me - try it.

  • 1
    nope... I don't have any "right click corners" because I don't have that chosen in the preferences. and I'm afraid this happens often even when fingers aren't wet, or "close to having mult. fingers touching, etc." I am wondering it is in fact when i do my perfectly legit drag gesture in a certain part of the trackpad. agg, it is annoying that I can't simply get an exchange on it just because it is very hard to replicate this very intermittent problem. Sep 26, 2011 at 8:45

I sometimes scroll on my Macbook when I meant to drag. In my case it's usually due to another finger touching the trackpad or palm pressure too close to it.


For me, it ended up being cleaning my keyboard, namely the Control key, which was causing the click to be a secondary click.


I have the same problem... I can avoid it by arching my fingers and clicking with just the tips, but I find that unnatural and uncomfortable, since my fingers are not as flexible as they once were. I think the trackpad sees my single click as a double click because the fingers contact it over a larger surface, and the pressure applied by the flat finger is probably not even. It seems like something that the trackpad software should handle, but there is no way to adjust the sensitivity settings for clicks.

There is no fix other than changing the way your fingers move over the surface.


I think the problem are the rubber of the magic trackpad. Try changing them.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .