2

I've never had this issue before:

I had an OWC ssd in my 2009 macbook pro, and I put it into a 2008 aluminum macbook. It worked perfectly. Then, I took it out and put it back in my macbook pro, but the computer wouldn't start up. It wouldn't even get past the grey screen (not even an apple logo!). Now it won't work in either computer.

I've tried starting up in recovery mode: nada.

I put it in my external HD enclosure and connected it to my macbook air. Nothing is showing up in the disk utility or in disk warrior (and yes, the enclosure works OK, I checked the SATA cable, etc, etc). I'm at a loss for what to do next.

1

This is more than likely a hardware problem with the SSD. Specifically, the SATA input/or SSD controller, based on the following:

  • The problem occurred after swapping the drive out from one machine into another.
  • You have connected the SSD to three different SATA cables (two internal, one external). None have recognized it. This rules out a bad SATA cable.

  • The drive is not recognized in any form of recovery. This rules out a corrupted filesystem.

  • The drive does not even mount when connected externally. This rules out a corrupted partition scheme and is a common symptom of physical failure.

All of the above point to physical failure of the drive.

First, I’d clean the SATA input on the drive using 99% isopropyl alcohol (not 91!%), then test again using the mentioned enclosure.

If it still isn’t mounting, at all, check the drive’s warranty and contact the manufacturer for a replacement, if applicable. Best of luck.

  • Awesome, thanks a ton for the suggestion. I tried to vote you up, but I guess stackoverflow points don't carry over to this forum, and I don't have enough reputation for the permission! – Dave Dec 11 '14 at 8:18
  • @Dave no worries! again, best of luck. cheers. – njboot Dec 11 '14 at 9:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .