15

Is it possible to set up a printer, so it will always print in black and white?

11

You can define a preset from the print dialog. First change the settings for what you want, and then choose the Presets > Save As… menu.

enter image description here

If you leave your preset selected, it will be selected the next time also, so you will never have to change it.

enter image description here

  • I don't see any options for that: cl.ly/7eXd cl.ly/7fWc – Tyilo Jun 15 '11 at 22:51
  • @Tyilo It's in the Presets menu, just under the printer selection menu. – ughoavgfhw Jun 15 '11 at 22:55
  • Oh my god, I'm stupid :P – Tyilo Jun 15 '11 at 22:56
  • This will not work for Google Chrome; Chrome will always use the default preset, not the last one used. – bouke Jan 19 '12 at 10:43
  • 1
    This depends on the printer driver in later versions of os-x. Many companies notably Canon do not provide a black and white option (greedy bastards). The only option is then to set it via CUPs. – max Apr 17 '16 at 14:17
23

@ughoavgfhw's answer is incomplete. Some applications (like Google Chrome) will not use the last used preset, but will use the default preset. In order to have such applications adhere to your default settings, you have to interact with the underlying printing system CUPS. These steps will get you there:

  1. Run cupsctl WebInterface=yes using the Terminal application (only required once).
  2. Browse to http://localhost:631/
  3. Go to Printers
  4. Select printer to modify
  5. Choose Set Default Options from the second drop-down
  6. Under Basic set Output color to Black (this step might be different for your printer)
  7. Hit Set Default Options and presto!

Set Default Options

Set output color to black

  • 1
    is there a way to do this strictly from the terminal ? – mcgrailm Feb 24 '15 at 21:28
  • When clicking "Set Default Options" I was prompted for a username/password with no explanation. After some confusion, entering my local Mac username (which has Admin privileges) and password worked. – TheKarateKid Feb 25 '17 at 18:00
  • When setting this via cups web interface, user can't print in color anymore. Did I do something wrong? – PVitt Feb 19 at 16:12
  • @PVitt this sets the defaults for the printer. If you want to print in color, you’d have to override that default in the print dialog. – bouke Feb 19 at 17:22
  • @bouke Exactly. But I can't select to print in color in the print dialog. This option is deactivated, as long as the default is set to BW. When I change the default to color, I can select BW in the print dialog. But not the opposite way. Any idea? – PVitt Feb 19 at 17:44

You must log in to answer this question.

protected by Community Apr 10 '15 at 19:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .