2

I need to install the rabbitmq management tool, but enabling results in the error (please see below). I am on OS X Maverick. I tried "rabbitmq-plugins disable Mochiweb" but Mochiweb could not be found

rabbitmq-plugins enable rabbitmq_management


********************************************************************************
Warning: Mochiweb enabled and Erlang version 17 detected.
Enabling plugins that depend on Mochiweb is not supported on this Erlang
version. At least R13B01 is required.

RabbitMQ will not start successfully in this configuration. You *must*
disable the Mochiweb plugin, or upgrade Erlang.

1 Answer 1

2

I just ran into this exact same error message when I enabled the rabbitmq_tracing plugin on Fedora21. Short story: you should be fine. RabbitMQ started right up for me with this plugin enabled (and all its dependent plugins including rabbitmq_management and Mochiweb)

I think there may be a problem with how RabbitMQ is detecting Erlang versions? From looking at http://www.erlang.org/documentation/ it appears that:

  • Release R13B01 maps to version 5.7.2
  • Release 17 maps to versions 6.x

So by running Erlang release 17 we appear to be running a sufficiently recent version to work with the Mochiweb plugin.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .