1

First, I apologize for the length of this. I want to make sure I get all the facts out so that hopefully I can get some help. There is s TL;DR version below if you don't want the blow-by-blow edition.

My wife has been complaining about the speed of her Late 2011 MacBook Pro for the last year. I finally broke down and decided to give it a boost by upping the memory to 16gb (from the stock 4gb) and replacing the 500gb HDD with a 480gb Crucial M500 SSD.

My plan was to simply swap the drives, replace the memory, then boot to System Recovery Mode (Cmd - R at boot) and do a fresh install. I started the Disk Utility and created a new partition on the SSD no problems. I think picked the option for "Fresh Install". The first thing I noted was that it wanted to install Lion instead of Mavericks, which was on it, but figured whatever...it would update as soon as I get things rebuilt. I would then use a Roswell SATA-to-USB cable to mount the old drive and do a "recovery" of all her old date. The system did the initial download as part of the System Recovery Mode, then said it was rebooting to complete the install. At this point, I got the white Apple screen with the spinner...but it kept spinning, and spinning, and spinning. No indication it was actually doing anything, just spinning.

I let it run for another hour or so, then finally killed it by holding the power for 10sec. I tried the install again, but again I get the white screen with the spinner. This happens at least one more time.

Finally I try a different approach. Once again, I boot to System Recovery Mode. I again erase the drive, but this time in Disk Utility I try to do a "Recovery" from the old drive to the new drive. I hit the 'Go' button, it says "Setting up..." for about 10min (I believe it was trying to calculate the time), then pops up with an estimated time to restore the new SSD from the old as 7hrs. I checked it a few times before bed to make sure the progress was moving, then went to bed at about 10% or so.

This morning, however, when I checked the status I find that it's still stuck at like 15%. The system is not locked up: I can move the mouse, drag the window, etc. I hit Cancel on the restoration, and it says it's cancelling, but nothing.

Another 20-30min later it still says "Cancelling...". So, once again I force-cycle the power, and once again I hit Disk Utility. This time, however, when I try to erase the disk, it gets to EXACTLY the same spot the restoration got stuck at, then pauses. I left it there when I left for work, but I have a feeling something is fishy that is causing it to do this.

TD;DR

I am trying to replace my wife's HDD with an SSD. I performed the following attempts using System Recovery to no avail:

  1. Fresh install of Lion...seemed to get stuck after reboot
  2. Restore using Disk Utility from the old HDD to the new SSD...stuck at 15%-ish, and now the drive will not erase (gets stuck at 15%-ish)

Question

Is the drive just bad or is there some other technique/process I need to use in order to change the drive out other than what I have tried?

  • Just a thought, have you tried putting the old RAM back in, just to verify it isn't causing the problem? – Flying Trashcan Dec 10 '14 at 14:26
  • That was going to be my next attempt, to go back to the 4gb ram that came with. I also thought about trying to see if I couldn't mount the old drive as the primary and temporarily replace the Superdrive with the SSD and do the copy over the SSD controller instead of across USB. I also have a Linux server lying about that I could use to do the copy if needed. It just seems strange that it keeps pausing at the same spot. – CodeChimp Dec 10 '14 at 18:01
  • Sure does. Maybe try and redownload the installer. – Flying Trashcan Dec 10 '14 at 18:07
1

I ran into somewhat similar troubles, and discovered that there were many bad blocks on the drive (also from Crucial). Using Disk Utility to do a 1-pass security wipe (choose "Security Options" from the Erase tab in Disk Utility while the drive is selected and ) solved the problem entirely. Do this while started up from another disk (or the Recovery partition if you don't have another disk, like a OS X Install Flash drive).

Also consider installing Trim after you get everything installed, though be aware that there are some issues with Yosemite.

  • If you have disk repair software such as TechTool Pro you can check the disk to see if it has bad blocks before taking this step. – Calion Dec 11 '14 at 0:18
  • I tried this last night, but it gets to the same spot in the progress and seems to get stuck. I RMAed the drive back to Amazon last night. A replacement should be here by Friday. I am beginning to wonder if I shouldn't have sprung the extra cash for the Intel or Samsung Pro instead. – CodeChimp Dec 11 '14 at 12:05
  • If it got stuck in the formatting process, then I can't think of anything else it could be but a bad drive. Good luck with the new one. – Calion Dec 12 '14 at 19:08
  • So, I got the new drive it. Plopped it in and tried a fresh install...same Apple screen with grey spinner problem. I am beginning to believe that this model SSD id simply not compatible with this mac. – CodeChimp Dec 13 '14 at 15:30
  • …That doesn't make sense to me. I'd call Crucial's tech support. – Calion Dec 20 '14 at 18:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .