8

I have been having issues with Finder and the Dock ever since the upgrade to 10.10.1 (I can't be certain they weren't there in 10.10).

I am unable to drag items off of the Dock (to remove them). I also can't drag items from the download stack that I have beside my trash can in the dock. Dragging the item simply does nothing. If I drag it somewhere and release the mouse button, it just opens the app/file.
And in Finder, I am only able to drag and move/copy 86 items. I can select more but when I drag them to a new folder or other location the most that will get moved is 86.

I have confirmed the issue with a friend but have several other friends for which everything is working fine.

I have a mid 2012 retina MBP and my friend has an older (2010 i think) non retina MBP. I have restarted several times and tried to find any sort of setting that might be turned off. Googling doesn't seem to turn up any information either. So I am mostly wondering if anyone else is having this issue and/or if it is an OSX bug or how to fix it.

Thanks.

Update

Running repair disk permissions from disk utility then restarting worked for a while. But then things went right back to not working again. Going to test some things to see what might be causing it to revert.

Update 2

It turns out that restarting does fix it temporarily and repair permissions has nothing to do with it. I am assuming I didn't notice this before because it is being caused by an application that was reopening (because I usually check off the "Reopen applications" option).

Update 3

For clarity, here are videos showing what the issue is.

In this video it is working as it should be (right after a restart):http://youtu.be/DO4KsLiLveo
In this video it is not working:http://youtu.be/V48UKWlG1sE

  • 1
    Have you tried a repair permissions? It sounds like the dock is locked, but that wouldn't explain the finder issues. – tron_jones Dec 10 '14 at 15:31
  • Repair permissions fixed all of it. Including the finder issues. Not sure why but it works now. – jpatters Dec 10 '14 at 18:35
  • Which application was reopening and causing the problem? – Flying Trashcan Dec 19 '14 at 15:20
  • I still haven't figured it out. Restarting or logout/login fixes it and then it randomly stops working again after a period of time. Are you having the issue as well? – jpatters Dec 20 '14 at 16:04
  • For the delete from Dock, I noticed that you need to drag much higher than before, and only then does the 'remove' text appear (I do miss the little puff of smoke). Your video appears to me that you are not dragging high enough. – cmason Jan 27 '15 at 15:40
10

I know it may seem totally unrelated, but if you have the Pushbullet extension installed for chrome, try disabling "Universal copy & paste". You may need a restart afterwards.

  • This is a definite possibility as I do have that enabled. Just disabled and restarted. I'll post back when I know if it has come back or not. Do you have steps to reproduce this with Universal Copy & paste enabled? – jpatters Jan 2 '15 at 14:19
  • I'd also be curious to know how you came to this conclusion. – jpatters Jan 2 '15 at 14:43
  • To be honest, it was a stroke of luck that I made the correlation. I was trying to find a solution to a separate issue discussed here and as a side effect it seemed to have resolved the drag and drop bug with the dock in Yosemite. I still haven't found the exact trigger that causes the issue. What I have noticed is that when "Universal copy & paste" was enabled, the drag and drop bug in the dock seem to occur within the hour. When disabled, the issue seemed to have stopped. – dvnguyen Jan 2 '15 at 17:26
  • After disabling universal copy and paste this have been working normally. Its been over 24 hours now. This is awesome. Thanks so much. – jpatters Jan 4 '15 at 16:31
  • 2
    This has been driving me crazy, so thanks for the solution. What I want to know is, how on earth can a mere Chrome extension (that doesn't require an admin password to install) hose system functionality like this?!? – Dan Herd Jan 14 '15 at 10:33
1

Repair Permissions cannot possibly fix this problem.

Repair Permissions only sets permissions on files/folders back to the permissions they were installed with, and only if they were installed using Apple's Installer. (And it doesn't even do that well.)

NOTHING in your home folder was installed that way.
NOTHING in your home folder will even be looked at by Repair Permissions.

Not your Dock. Not anything on your Dock. Not Dock's preferences.

Let's look at things that might actually cause the symptoms described.


First, there used to be a problem where people would accidentally drag things off their Finder sidebar and wonder where they'd gone. Apple fixed that by requiring you to hold down the command key while dragging items off the sidebar, which was consistent with the way toolbar items and menubar items work. That led to a rash of queries: why can't I drag anything off my sidebar any more? Yosemite went back to the old behavior: you no longer need to command-drag to get things off the sidebar. (Instead, it seems you now need to command-drag to put something on the sidebar! I wonder whose bright idea that was?)

Why am I talking about the sidebar when the question is about the Dock? Because we expect the UI to behave the same everywhere. You still need to command-drag to take something off the menubar or toolbar. You used to need command-drag to remove something from the sidebar. It feels intuitively obvious that you should need to command-drag to get something off the Dock.

But surprise! On Yosemite, command-drag to or from the Dock "locks" the Dock for the duration of the drag. The reason is to make it easier to drag something onto an app or into a folder that's on the Dock. By command-dragging, you stop the Dock icons from dancing away from your mouse. It even lets you drag a document that's on the Dock onto an app that's on the Dock. Normally, drag-and-drop from the Dock would remove the document from the Dock no matter where you tried to drop it. But now, command-drag from the Dock signals that you're trying to drag-and-drop the item, not remove it.

So, just as a wild guess, is it possible that you can't drag from the Dock because you're holding down the command key? Muscle memory is insidious. It makes you do things without even realizing you're doing them.


As another wild guess... I tried to use a friend's Mac, and kept running up against walls like this where things just weren't working as expected. It turns out my friend likes Sticky Keys, and has it turned on all the time. I'd carelessly press the control key to do something, then change my mind, blissfully unaware that the control key was now stuck down. Everywhere I clicked, a contextual menu would pop up surprisingly. I didn't realize what was going on because I rarely use a MacBook Pro and thought it was just my muscle memory not adapting to its tiny (by comparison) trackpad.

So, is it possible that you're accidentally turning on Sticky Keys? It's easy to do. Just tap the shift key five times without pressing an ordinary key. Then it's easy to start doing command drags without actually holding down the command key. Tap the shift key five more times to turn it off.

0

I know that when dragging items off of the Dock to remove them, it has changed slightly. Previously, as soon as you would drag a item off the Dock and release the mouse button, it would disappear. Now, when I drag icons off the Dock, I need to hold the icon off the Dock for a second or two before it realizes I'm intending to remove it. A little annoying, but not a game changer.

If you are still having issues with the Dock, you can try the terminal command

killall Dock

The next thing to try would be to Repair Permissions. Open Disk Utility, select the drive from the list on the left, and click Repair Disk Permissions. When it is finished, restart your computer. According to Apple, repairing the permissions only applies to "files installed by the Mac OS X Installer, Software Update, or an Apple software installer. It doesn’t repair permissions for your documents, your home folder, or third-party applications."

  • I realize they changed that, but when I drag something off of the dock, it doesn't move with the mouse. The icon stays in the dock as if im not holding the mouse button down. killall Dock does nothing to help it. Restarting doesn't either. – jpatters Dec 10 '14 at 15:12
  • Hmm... try repairing the permissions with Disc Utility. I editted my answer to include the directions. – Flying Trashcan Dec 10 '14 at 15:56
  • 1
    Repair permissions worked. Had to restart though. Add that to your answer and I will accept it. Thanks! – jpatters Dec 10 '14 at 18:34
  • Sorry, I guess I jumped to a conclusion too quickly. Repair permissions isn't what was making it work again. – jpatters Dec 11 '14 at 13:19
0

I found the only correct answer to remove the unwanted items that are on the dock is to shutdown the computer and then go through a restart and the items that are not wanted will still be there, then arrow over the item in the dock not wanted and right click and hold down and you will see one of two things Quit or Force Quit, arrow over one of these let go and its gone. Try it it works, glad to help

0

I have in the past had occasional mishaps and accidentally removed items from the dock. In Yosemite, to my delight, I found that I have to drag the item farther away from the dock toward the center of the screen before they go poof. This prevents those accidental removals.

  • 1
    Please read the whole post and watch the clips before you answer the question. – jpatters Feb 9 '15 at 19:47

You must log in to answer this question.

protected by Community Feb 9 '15 at 20:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .