0

tl;dr

When I hold alt during boot, and select the Recovery partition, the computer displays the bright grey screen with an Apple logo, and a spinning work indicator. But after a few hours nothing has yet happened.

Running an updated Yosemity install

Long version

I was working on a rake script which tried to create a directory relative to my home folder. I used a ~ in the script, where I should have used the $HOME environment variable.

No big deal, that just created a folder named ~ in my current working directory. Of course this shouldn't be there so I deleted it with

rm -rf ~

Bad idea! After about a second, I realized what I had done - that I had asked it to delete my home folder, and I immediately cancelled the operation with ctrl+c

I didn't assume that this should be a big deal. Just restore my home folder from a Time Machine backup - the only work I had done since the last backup was already pushed to a remote git repository.

Well, restoring my home folder from a Time Machine backup resulted in an error code, so I created a new administrative user, logged in as that user and tried again.

Still error messages, so I opened a terminal, and got the message that '/bin/bash' did not exist !!!

So my command apparently destroyed essential system software. How should that be possible when I wasnt sudo'ing anything?

So my next plan was to recover the computer from said Time Machine backup. So I held the alt key pressed during startup (where the background is now black, instead of the usual light grey), I select the Recovery partition. And then nothing happens.

Booting normally into OSX doesn't work either. I get the normal boot progress bar (but with a black background instead of a grey) - but it freezes about 1/3 way in.

How do I get to a point where I can recover from my Time Machine backup.

Is it just trying to download software from Apple? Do I just have to be patient?

  • as no-one's chimed in yet after 5 hours, on a nicely detailed post - try Cmd/R at boot, should put it into recovery mode. support.apple.com/en-gb/HT4718 Should get you back to a point you can pull in Time Machine backups at least. – Tetsujin Dec 10 '14 at 18:38
  • @Tetsujin - that could be an answer instead of a comment. I have tried it, got it into "Internet Recovery", and it is currently restoring from the Time Machine backup - 33 hours to go. – Pete Dec 10 '14 at 20:57
  • Let me know how it goes - I'm not sure one key combo & a quick link deserves the points, but I wish you luck :) – Tetsujin Dec 10 '14 at 21:01
  • At first attempt, something went wrong - when I checked up on it in the morning the screen was black, and the computer was unresponsive, and I had to force restart by holding the power button. It then could boot, but it the system was in a partly corrupted state. I then purchased an Ethernet cable network adapter and tried once more (backup is on a network device), and after about 10 hours, it is now up and running :) – Pete Dec 11 '14 at 23:58
  • Glad to hear you got there in the end :) – Tetsujin Dec 12 '14 at 7:27

You must log in to answer this question.

Browse other questions tagged .