18

I just got a new 13" rMBP with Yosemite installed. I chose to enable FileVault when I set the machine up.

Now, several days later, an app called "Reverting from FileVault" shows on the list of apps consuming a lot of energy. [Edit: this app no longer shows up; everything else in this post is still true.]

I check FileVault in System Preferences, and it says "Encryption paused," followed by "Connect power adapter to resume encryption." Connecting the power adapter makes no difference, even though the machine recognizes that it's charging.

I've found several threads describing this problem, but no solutions.

I've tried resetting the SMC, clearing the PRAM, going into Recovery Mode, repairing the disk and repairing permissions. Nothing has worked. I can't stop FileVault from Terminal, and when I try to enable it, it says it's already on:

$ fdesetup status
FileVault is On.
Encryption in progress: Pending

$ sudo fdesetup disable
Password:
Enter a password for '/':
...

$ fdesetup status
FileVault is On.
Encryption in progress: Pending

$ sudo fdesetup enable
Error: FileVault is already On.

Here is the output of diskutil cs list:

$ diskutil cs list
CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group 25ED6E9D-5D22-4846-9C2A-2698F58A1159
    =========================================================
    Name:         Macintosh HD
    Status:       Online
    Size:         250140434432 B (250.1 GB)
    Free Space:   0 B (0 B)
    |
    +-< Physical Volume 32AF849E-36C7-4587-AF3E-3BEC1D517A69
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     250140434432 B (250.1 GB)
    |
    +-> Logical Volume Family F3D38571-E46C-4A52-9C1A-71B9737E0A79
        ----------------------------------------------------------
        Encryption Status:       Unlocked
        Encryption Type:         AES-XTS
        Conversion Status:       Converting
        Conversion Direction:    forward
        Has Encrypted Extents:   Yes
        Fully Secure:            No
        Passphrase Required:     Yes
        |
        +-> Logical Volume 4362CD83-5AAB-4DA5-BD4E-17BC5CCAEB49
            ---------------------------------------------------
            Disk:                  disk1
            Status:                Online
            Size (Total):          249820610560 B (249.8 GB)
            Conversion Progress:   Paused
            Revertible:            No
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS

When I search Console for corestorage, I get many entries like the following:

12/13/14 8:41:45.067 PM corestoraged[155]: 0x7fff78553300 resumeBackgroundConversion: background conversion started/resumed for lv 4362CD83-5AAB-4DA5-BD4E-17BC5CCAEB49.

And others like this:

12/13/14 8:41:45.000 PM kernel[0]: CoreStorageLogical::resumeBackgroundTransform: thread already running

Any suggestions? The machine is brand new, so there isn't a HUGE amount of data on it (nor are there any Time Machine backups), but I'd like to avoid having to wipe the drive.

If there's nothing I can do, does Apple have a history of issuing hotfixes for issues like this?

  • 1
    I unloaded and disabled the corestorage deamons (There's a corestoraged, and a helper), restarted and reset the pram, repaired my disk in safe mode, and finally restarted again. Then I re-enabled the deamons and it seemed to get unstuck. Not posting this as an actual answer, because I have no idea if it's really a solution, or it just worked for me. – markwatson Dec 19 '14 at 0:34
  • @markwatson I referenced a similar process in my answer. Is that the same one you followed? – Peter Dec 19 '14 at 4:03
12

I asked after this while attending WWDC 2015 and was told that the "Encryption Paused" issue was addressed in 10.10.3.

The root cause was a problem with resizing the CoreStorage volume during the encryption process. When the CoreStorage volume was unable to grow, the encryption was paused and could not resume until the resize issue was addressed.

To fix this issue:

  1. Update your Mac to 10.10.3 or boot from an alternate drive which is running 10.10.3.
  2. Unlock the encrypted drive if necessary
  3. Open Terminal
  4. Run the following command to get your Mac's disk identifier:

    diskutil list
    
  5. Once you have the disk identifier information, run the following command with root privileges:

    fsck_cs -y disk_identifier_goes_here
    
  6. fsck_cs should repair the CoreStorage volume and address the resizing issue. As part of the output, it should show that encryption is resuming.

  • Thanks for your response. While I'm unable to test this (having already fixed the problem with the workaround I described in my answer), I'll assume it's the proper solution. – Peter Jun 30 '15 at 17:24
  • Unfortunately this did not work for me. Too bad. – Ben Wilde Sep 4 '15 at 17:11
  • 1
    Disk Utility as of El Capitan also seems to have provided a way to address "Encryption paused" because of the sizing issue. Following instructions recently posted in one of the many Apple Support threads, I booted from a USB El Capitan install disk, ran Disk Utility and during First Aid saw: "The volume @@@ was resized to unblock Paused encryption". Now all is well, finally. discussions.apple.com/message/29014455#29014455 – npdoty Oct 18 '15 at 8:44
  • You're an absolute life saver. I've tried everything out there and this did the trick. – InkGolem Sep 7 '16 at 20:54
  • I am running 10.12.5 but I still ran into this problem (so it is not dead yet!) ZOMBIES! I get "the volume disk0s2 cannot be repaired when it is in use" when I try this patch. I guess I must try boot from another volume. Thanks for all the detailed answers on this thread. – micstr May 22 '17 at 18:32
8

I spoke with Apple and my case was escalated. I sent in logs for the engineers to evaluate, and they determined that the FileVault encryption had failed. As other users have reported, the only suggestion was to make a Time Machine backup, wipe the drive, reinstall Yosemite, and restore from the Time Machine backup.

A few important notes (from forum posts I've read):

  • When you wipe the drive, select Journaled. It defaults to Journaled, Encrypted, but leaving encryption enabled will not solve the problem.
  • A Time Machine backup is not required to wipe the drive and reinstall OS X Yosemite, but it's the easiest way to retain your data.
  • You must un-check FileVault during the initial OS X setup, otherwise this problem might reoccur. Of course, it might work the second time around... but why take the risk? Wait for Apple to fix this bug before you enable FileVault again.
  • If you restore from the Time Machine backup during the OS X installation, you won't be prompted to enable FileVault and it should be off by default.

If this solution is not satisfactory, you might find some guidance from this guide on failed FileVault encryption. I considered a similar approach (I found that guide by searching Google for "killing corestoraged"), but ultimately decided to go with the tried and true (and tedious) approach of a full reinstall.

For posterity, a partial excerpt of the aforementioned guide:

So scanning for the according process turned out that corestoraged was causing the high load. Giving it a 50/50 chance to fix it or to destroy my system completely I had an idea how to fix it. So first I tried to simply kill the process. That worked but after a few seconds the process reappeared – so it must have been started from another daemon. It turned out that actually the launchd is kicking off this process. So either to go through the whole tutorial [2] I decided to do a quick fix/trial. So my idea was to move the daemon binary and than to kill the process. So I did the following:

firebird:~ jvr$ mv /usr/libexec/corestoraged /usr/libexec/corestoraged.old
firebird:~ jvr$ killall corestoraged

And suprisingly the load dropped, while my operating system was still working. Please note that this is highly risky and I would not recommend to do it unless you don’t see any other options.

It should be also noted that there is definitely a better solution in place related to the launchd configuration. Neither the less Apple should get their FileVault running stable, especially since it has to be considered as a core service.

[2014/09/09] Update: Already giving up my hope to fix the issue permanently, I started to backup my MacBook and prepare for a re-installation. Even if the above workaround resolved the CPU usage & power consumption issue, I did not feel comfortable moving around core processes, where I was not 100% sure what they are doing. So I backed up everything and started cleaning my machine. Having everything done so far I decided to start the Mac in Recovery mode and try one more time the disk repair functionality (especially the fix permissions). After doing this, I thought I give it one more last try. Booted up, moved the corestoraged back and checked in the FileVault progress screen within the Security Settings. And suddenly I saw that the encryption process was working again. This time I did not touch the machine anymore until the encryption was finished.

And what I have learned from this lesson – do backups. And the second lesson I’ve learned: never go the easy way and start reinstalling your operating system.

6

I want to share the solution that fixed the problem for me.

First of all, my El Capitan install failed, resulting in that after boot the login screen was shown, but after a login, there was a kernel panic and the Mac restarted.

So I tried to reinstall via the Recovery Mode, but at the point of selected the HD, I got this message: FileVault conversion in progress. Use the "Security and Privacy" preference pane to check conversion status.

These steps solved my problem:

  • Go the Recovery mode (hold cmd + R during boot)
  • Open a terminal, and type: diskuitl cs list result: Conversion Progress: Paused
  • I opened a second terminal window
  • Searched for the binary 'corestoraged': file / -name 'corestorage*'
  • Found it in the recovery folder: /usr/libexec/corestoraged
  • Started corestoraged in the found folder: ./corestoraged
  • Now check the HD via the first terminal, the Conversion progress now showed a percentage, and after an hour, the HD was converted.
  • Then I could reinstall El Capitan from the same recovery mode.
  • After the reinstall, everything was like it was.
  • 2
    This is the real answer – jakethedog Nov 14 '16 at 17:55
  • 1
    Thanks. This worked for me with an external disk that was paused (I wasn't trying to reinstall macOS or anything). Just had to unlock the disk first with diskutil coreStorage unlockVolume {logical id}. – G-Wiz Mar 18 '17 at 20:40
  • 1
    Thanks - invoking /usr/libexec/corestoraged from Recovery mode started the progress and it seems to have completed overnight when I had a failed install of High Sierra and I turned off FV from the command line in Recovery mode. Hopefully the installation can complete now without the added FileVault complication. – j-beda Dec 9 '17 at 13:22
2

Get the latest update to Yosemite! After checking for various fixes, installed 10.10.3 and issue resolved itself.

1

Here's what worked for me based on this post from the Apple forum:

  1. Reboot and reset PRAM by holding Option+Command+P+R
  2. It quickly rebooted again and I held Command+R to enter recovery mode.
  3. Select Disk Utility
  4. I saw my base "Macintosh HD" plus an encrypted "Macintosh HD" beneath it. Select the encrypted partition and then select File/Unlock and enter your password.
  5. Select "Repair Disk" (took 1-2 minutes)
  6. Select "Repair Disk Permissions" (took 1-2 minutes)
  7. Select the base "Macintosh HD" partition and select "Repair Disk" (took 3-4 minutes)
  8. Reboot (Apple menu I think)
  9. Log in and open System Preferences/Security & Privacy/FireVault
  10. Encryption was still "Paused" at this point, but I disconnected and reconnected my power and then encryption restarted and finished quickly (<1 minute).

Hope that helps.

  • 2
    Unfortunately, this did not work for me. – Peter Dec 14 '14 at 1:19
  • 1
    No luck using that method, I have even tried disabling encryption in Recovery mode, nothing changed. – Igor Zinov'yev Dec 15 '14 at 15:11
  • The option to disable encryption is grayed out for me in Recovery Mode. – Peter Dec 15 '14 at 16:20
  • Using macbook pro retina mid 2014 This did not work for me – user104936 Dec 16 '14 at 3:56
  • 1
    @Peter, you can un-grey the option if you open the 'File` context menu while pressing the Option key. Don't forget to release the key before clicking "Turn Off...". It's no use, though, it doesn't work. – Igor Zinov'yev Dec 16 '14 at 13:58
1

I second Peter's (Dec 18) comments.

I had a brand new out of the box 11" MBAir picked up this December 2014. FileVault paused during set up asking for the power adapter.

A senior Apple advisor said Apple engineers say there is nothing wrong with the computer - you can use it.

What you can't do is turn FileVault off. The engineers consider this a cosmetic issue. Their first suggestion is to leave the laptop on without sleep for 24 hours - they discovered that in "many cases" the error resolves itself.

Since I had no data on the drive (see Peter's suggestions if you do), they had me wipe the drive in Terminal, initiate a netboot, select "Reinstall Yosemite" from the OS X Utilities windows that follows a netboot. Then, after download and install, DON'T activate FileVault during set up. (apparently wiping the drive in Terminal is important - reinstalling Yosemite alone won't solve the problem).

So far my laptop now appears good as new.

1

I've been looking into this problem for about a year (my laptop has FileVault enabled since its initial installation but never completed. I ended up doing the following double copy to and from a USB drive:

  1. Use SuperDuper to create a full system backup on a USB drive.
  2. Boot from it (SuperDuper does that automatically)
  3. Use Disk Util to recreate the main partition. (*)
  4. Use SuperDuper again to create a backup of the main partition on the USB drive onto the now fresh partition.
  5. Boot from the internal drive again.
  6. Restart FileVault, and this time let it complete before anything else ...

(*) If you accidentally deleted the Recovery Partition, you can recreate it by booting into Recovery Mode (Cmd-R) and 'Reinstall Yosemite', which will only reinstall the OS, but will leave your data alone.

I hope this helps people recover nicely from this problem. Now onto installing the Captain.

0

This issue can also be caused by the UPS (Uninterruptable Power Supply) bug in El Capitan (same thing that's keeping Time Machine from running automatically).

I ran into this on a brand new machine. The Disk Utility repair did nothing, but I remembered reading about the UPS & Time Machine bug. When I disconnected the UPS and rebooted, both Time Machine and File Vault worked normally.

If you have a UPS and are running El Cap, disconnect the UPS and reboot. Try this first and you will probably save yourself some time.

-6

Try smc reset and reboot the computer will be ok

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

You must log in to answer this question.

protected by Community Jan 25 '16 at 15:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .