4

I had a strange issue recently where I had to reset PRAM after using an HDMI cable with my MBP (it had a blank screen on boot).

I feel like this is again related to the HDMI cable. After using it, all my Desktop icons have disappeared. I've run killAll Finder and rebooted and it hasn't restored them. Trying to avoid resetting PRAM again.

  • how about safe mode? – Ruskes Dec 10 '14 at 7:36
  • No luck with that – kylemclaren Dec 10 '14 at 10:02
2

I had the same problem, I think. But my files were still in the finder under 'Desktop', just not on the actual desktop. After trying a few of the above, I second-clicked the desktop and hit 'Clean up', and they all reappeared. So the simplest of all helped for me.

  • Thank you! That was it! I have my icons snap to the grid so I rarely use cleanup. – kylemclaren Feb 21 '15 at 9:54
  • not sure it it'll work in your situation, but icons on my desktop are often not visible (I get a garbled image half the time too!). The way I cure it is to drag across the desktop, "selecting" everything on it. This causes the it to be rendered, and lo, there they are! In my case, they've not actually "gone" but arent visible (I can right click them if I know where they are). – drevicko Jun 9 '15 at 10:42
1

This just happened to a teacher at my site. After repairing disk permissions (Disk Utility) and restarting the computer, everything reappeared.

1

Try rightclicking the mouse on the desktop, and choose "Clean Up" - it worked for me :)

0

First (with HDMI connected, in multi-display environment):

Open System Preferences > Mission Control > uncheck “Open Displays as separate spaces.”

Log out and log back in. Any luck? If not...


Second:

Start up in Safe Mode. Among other things, this purges certain system caches, which may be corrupted, and subsequently rebuilds them.

Shut down your machine, and then restart it while holding Shift at the chime (let go after two seconds). Log into your user account. Log out. Restart normally. See if the issue persists.


Third:

  1. Log into your user account
  2. Click the Finder Icon and press the key combination ShiftCommandG to bring up a “Go to Folder” Window.
  3. Select the following text. Copy it, then paste it into the window ~/Library/Preferences/com.apple.finder.plist . Move the file to your trash. Log out, then back in. Finder preferences will be reverted to defaults.
  4. If it’s still happening, repeat (3) for the following: ~/Library/Preferences/com.apple.dock.plist

    ~/Library/Preferences/Byhost/ . Inside this folder, trash any com.apple.finder* file. ~/Library/Preferences/Byhost/ . Inside this folder, trash any com.apple.dock* file.


Fourth:

if necessary...

  • Thanks for all those answers, really appreciated. I tried everything in order, no luck. I've restored the plist files from yesterday and no effect either. I've even tried defaults write com.apple.finder CreateDesktop -bool true. No luck either. – kylemclaren Dec 10 '14 at 9:34
  • @KyleSA you’re welcome. have you attempted to recreate the behavior in another user account? If not, try to do so now. The guest account won’t suffice in this case. make another administrative account if necessary and see if the behavior either persists, or reoccurs when unplugging/plugging back in HDMI cable. This way, we can attempt to isolate the problem (your account vs system wide). Also, run Etrecheck and copy the contents of the report to Pastebin. Supply the link in your reply. Etrecheck anonomizes any personal information. – njboot Dec 11 '14 at 6:07
  • It had this behavior. It seems to be the icons are there but off the screen. If I drag a new file to the desktop and press [CMD] + [A] to select all, I see the other files as i drag them around. Not been able to drag them back into view, though. – Marc Dec 12 '14 at 12:30
  • @Marc right click (or control + click) anywhere on the desktop. Select View Options > Snap to Grid. Close that window. Right click on the Desktop again, Clean Up By.. > Name. – njboot Dec 12 '14 at 22:24
0

I had the same issue - but finally discovered it was due to Parallels Desktop = just click on 'Hide Desktop' and everything came back. Must be some setting which I mucked around with.

-1

After installing a Yosemite update, my desktop icons all disappeared. I had three desktops open and I noticed that when I paged back and forth between the desktops, the icons would appear momentarily and then disappear. Solution: I closed down the two extra desktops and the icons reappeared. I then added two new desktops and the icons did not disappear on the new desktops. Thankful for a simple solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .