1

2 days (on Sunday) ago I performed clean OS X Yosemite installation over OS X Yosemite that was upgraded from Mavericks previously. I have a time machine backup. So, latest backups in time machine was written by Yosemite.

In new system I have an account with the same username.

Now I tried to restore some folders from time machine but I was not able to find my home directory in time machine. It has my home directory from new OS installation, but not previous. I tried browsing using time machine and Finder as well. There is no home folder for my account.

What's interesting is that it has this directory after reinstall and I restored several directories even yesterday, but not it is missing.

Any ideas what happened and how to restore it?

I can't think of anything other than VERY SERIOUS Time Machine bug.

  • If you navigate to /Users/, and then enter Time Machine, does it show two version of the same username? – Flying Trashcan Dec 9 '14 at 15:19
  • No, it has no username in backups prior to reinstall, and only one username after that – Vladimir Prudnikov Dec 9 '14 at 16:04
  • How much larger is the Time Machine compared to one single complete backup? I'm thinking there's the possibility it ran out of space & cleaned up the oldest stuff. One safety aspect when doing a major upgrade is to remove the Time Machine drive immediately afterwards until you're certain the new install is all you expected it to be. – Tetsujin Dec 9 '14 at 17:52
  • 2-3x larger. When there is no space for new backups it deletes oldest backup, not biggest folder. I still have couple months of backups, but there is no home folder. – Vladimir Prudnikov Dec 9 '14 at 19:55

You must log in to answer this question.

Browse other questions tagged .