I'm having trouble zipping a .app file. If I zip without -r (recursive) it is really shallow, if I zip with -r it's really dense. The zip doesn't unzip correctly regardless.

1 Answer 1


From the man page for ditto:

ditto -c -k --sequesterRsrc --keepParent src_directory archive.zip
  • This still isn't preserving codesigning, although it does answer the question. :/ Commented Dec 8, 2014 at 20:52
  • @ThomasReggi, I just tried it with code signing and it worked for me. Is there something unusual about your app like a non-Mach-o executable?
    – JWWalker
    Commented Dec 8, 2014 at 21:36
  • Not sure what that is I just signed and got signed bundle with Mach-O thin. I'm signing with this command codesign --verbose --deep --force --sign "Company, LLC." Atom.app I'm lost and can use any help, when I verify I get nested code is modified or invalid Commented Dec 8, 2014 at 21:43
  • I figured it out with this stackoverflow.com/questions/20266954/… Commented Dec 8, 2014 at 22:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .